Bug 2026950

Summary: No more auto focus in Search section of the OCP v4.8.18 web console.
Product: OpenShift Container Platform Reporter: Utkarsh Wagh <uwagh>
Component: Management ConsoleAssignee: Joe Caiani <jcaiani>
Status: CLOSED ERRATA QA Contact: Yanping Zhang <yanpzhan>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.8CC: aos-bugs, jcaiani, jokerman, jonjacks, mmarkand, yanpzhan
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-12-14 11:45:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1965365    
Bug Blocks:    

Description Utkarsh Wagh 2021-11-26 15:33:01 UTC
Description of problem: The feature of automatic focus on the search text area for the resource section from the web console of OCP v4.8 is removed.


Version-Release number of selected component (if applicable): OCP v4.8.18


How reproducible:
[1] Observe the web console of OCP 4.6/4.7 there is an automatic focus on the text area of the resource section, To be more precise: You can choose which type of resources you would like to search for. By clicking on the Resources, in the earlier version,(4.6,4.7) you would get auto-focus on the text area in which you could choose the suggested resources type.

[2] Observe the web console of OCP v4.8 onwards, the automatic focus on the text area would not work, You have to click on this resource section, then click on the test area to choose the resource type.

Steps to Reproduce:

1. Compared the web console from OCP v4.7.23 and OCP v4.8.13.

2. There is a difference in automatic focus on the text area in the resource section.


Actual results: There is no autofocus in OCP v4.8 onwards, but the feature was present in OCP v4.6 and OCP v4.7.


Expected results: There should be an autofocus feature available in OCP v4.8 onwards as well.


Additional info: 
[1]The Customer wants the automatic focus to the text area in the resource section should be available for OCP v4.8 version.

[2] Has concern about why it was removed in OCP v4.8.

Comment 6 errata-xmlrpc 2021-12-14 11:45:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.24 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4999