Bug 2028156

Summary: thousands of "hardlink: cannot link" errors while kernel update
Product: [Fedora] Fedora Reporter: Andrew <travneff>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: acaringi, adscvr, airlied, alciregi, bskeggs, danny, gwirth79, hdegoede, jarodwilson, jeremy, jglisse, jonathan, josef, kernel-maint, lgoncalv, linville, masami256, mchehab, ptalbert, steved, thedatum+bz
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-01-12 00:21:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
complete log from "dnf update" none

Description Andrew 2021-12-01 15:45:14 UTC
Created attachment 1844361 [details]
complete log from "dnf update"

Have a lot of prints like this while running `dnf update`:

  hardlink: cannot link ./drivers/perf/Kconfig to /usr/src/kernels/5.15.4-201.fc35.x86_64+debug/./drivers/perf/Kconfig.hardlink-temporary: File exists

Appeared more than one month ago (saw this for previous updates as well).

Complete log attached.

Comment 1 Danny Ciarniello 2021-12-15 03:49:10 UTC
Just saw the same thing with the update to kernel 5.15.7-200

Comment 2 Gus Wirth 2022-01-01 19:23:07 UTC
This a dupe of 2025157. That bug report has a better explanation of what is going on. Although it doesn't seem anyone has been assigned to fix it yet.

Comment 3 Eike Rathke 2022-01-12 00:21:17 UTC

*** This bug has been marked as a duplicate of bug 2025157 ***