Bug 2028307

Summary: [4.8] Do not restart Kuryr-Controller when LB is stuck in PENDING_UPDATE state or Neutron port is DOWN
Product: OpenShift Container Platform Reporter: Robin Cernin <rcernin>
Component: NetworkingAssignee: Robin Cernin <rcernin>
Networking sub component: kuryr QA Contact: Itzik Brown <itbrown>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: dpateriy, itbrown
Version: 4.8   
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 2030486 (view as bug list) Environment:
Last Closed: 2022-01-11 22:31:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2030486    
Bug Blocks:    

Description Robin Cernin 2021-12-02 00:35:46 UTC
Description of problem:

This is back port of 

https://review.opendev.org/c/openstack/kuryr-kubernetes/+/812246 +
https://review.opendev.org/c/openstack/kuryr-kubernetes/+/796881

into 4.8, the same code + prometheus are present in 4.9 and 4.10

Version-Release number of selected component (if applicable):

4.8

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Itzik Brown 2022-01-04 12:33:47 UTC
Verified with 4.8.0-0.nightly-2021-12-23-010813

Followed https://bugzilla.redhat.com/show_bug.cgi?id=2030486 , added a deployment and after moved the LB to PENDING_UPDATE , scaled the deployment and after some time saw the exception in the log

Comment 7 errata-xmlrpc 2022-01-11 22:31:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.26 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0021

Comment 8 MichaƂ Dulko 2022-02-23 10:59:45 UTC
*** Bug 2056233 has been marked as a duplicate of this bug. ***