Bug 2028680

Summary: RFE: please add themes to virt-viewer's preferences
Product: [Fedora] Fedora Reporter: Todd <ToddAndMargo>
Component: virt-viewerAssignee: Daniel Berrangé <berrange>
Status: NEW --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 35CC: berrange, cfergeau, fabiano, marcandre.lureau, victortoso, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Todd 2021-12-02 23:04:22 UTC
Fedora 35
virt-viewer-10.0-4.fc35.x86_64

As of Fedora 35, virt-viewer now defaults to a "dark" theme. This is a pain in the neck (not my exact word) as it makes so I can not tell the edges of my virt-viewer window and have actually shutdown my host a few times by accident.


This is my workaround:

bash -c "GTK_THEME=Adwaita:light remote-viewer spice://127.0.0.1:5905"

In virt-viewer's decorations, there is a preferences option. Would you please add at least the following three theme choices:

Dark
Light
System

And yes, I know developers like dark themes as light attracts bugs, but the rest of us have to use it.

Many thanks,
-T

Comment 1 Todd 2021-12-03 21:55:11 UTC
Please make the default "System"

Comment 2 Todd 2021-12-03 22:00:29 UTC
Just added:

RFE: please add themes to virt-viewer's preferences
https://gitlab.com/virt-viewer/virt-viewer/-/issues/62

Comment 3 Ben Cotton 2022-11-29 17:26:06 UTC
This message is a reminder that Fedora Linux 35 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 35 on 2022-12-13.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '35'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 35 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.