Bug 2031854

Summary: CI tests needed to confirm driver-toolkit image contents
Product: OpenShift Container Platform Reporter: dagray
Component: Driver ToolkitAssignee: dagray
Status: CLOSED ERRATA QA Contact: Walid A. <wabouham>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.7CC: aos-bugs, wabouham
Target Milestone: ---   
Target Release: 4.9.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 2031826 Environment:
Last Closed: 2022-01-04 18:41:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2031826    
Bug Blocks: 2031938    

Description dagray 2021-12-13 15:14:04 UTC
+++ This bug was initially created as a clone of Bug #2031826 +++

In some recently published z-stream releases of OCP, the driver-toolkit image contained the wrong kernel package versions. One measure we can take to avoid this going forward is to run an e2e test script against each nightly build of OCP to confirm the correct package versions are being installed.

To allow for customizations of the tests for certain releases, and to simplify the ci-operator configs, this e2e test script should be backported to 4.8, and a simple version of it should be added to 4.7.

Comment 1 Walid A. 2021-12-13 18:54:31 UTC
Verified. The e2e script is in the release4.9 branch:  
https://github.com/openshift/driver-toolkit/blob/release-4.9/test/e2e

Comment 5 errata-xmlrpc 2022-01-04 18:41:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.12 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:5214