Bug 203275

Summary: Missing tcl subpackage and non-conditionalized subpackages
Product: [Fedora] Fedora Reporter: Robert Scheck <redhat-bugzilla>
Component: rrdtoolAssignee: Jarod Wilson <jarod>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: extras-qa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-11-14 19:13:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Diff of rrdtool spec files none

Description Robert Scheck 2006-08-20 10:49:43 UTC
Description of problem:
I saw you sent rrdtool spec file of Fedora Extras upstream - fine! But in cases 
like this I would like to see the subpackages/rrd bindings conditional, because 
not everybody likes PHP or Python binding always when building rrdtool RPM from 
upstream spec file.

As I'm rebuilding the Extras rrdtool package always for different reasons, I 
just conditionalized the packages and added the missing tcl subpackage/binding. 
Maybe you can apply the patch to the next build. Everything should behave like 
in the past, but there's the new rrdtool-tcl subpackage now. If you don't like 
it for Fedora Extras, just change the line
  %{!?with_tcl:%define with_tcl 1}
to
  %{!?with_tcl:%define with_tcl 0}
for getting the old behavior.

Version-Release number of selected component (if applicable):
rrdtool-1.2.15-3

Actual results:
Missing rrdtool-tcl subpackage/binding, non-conditional bindings.

Expected results:
Apply of my attached patch or better ;-)

Additional info:
I didn't conditionalize the perl binding/subpackage, because perl is a build 
requirement, so it doesn't make really sense in my eyes.

Comment 1 Robert Scheck 2006-08-20 10:53:41 UTC
Created attachment 134525 [details]
Diff of rrdtool spec files

Comment 2 Robert Scheck 2006-09-23 17:23:48 UTC
Jarod, ping?

Comment 3 Robert Scheck 2006-10-18 20:41:22 UTC
Hey...somebody alive?

Comment 4 Jarod Wilson 2006-10-25 15:41:25 UTC
Sorry, been insanely busy with other stuff the past few weeks, then was on
vacation. This is on my todo list...

Comment 5 Jarod Wilson 2006-10-25 21:13:36 UTC
Just pushed new builds with the tcl sub-package, but holding off on the
conditionalization for the moment.

Comment 6 Robert Scheck 2006-10-25 21:16:13 UTC
Why - any special reason?

Comment 7 Jarod Wilson 2006-10-25 21:58:10 UTC
I may want to do the conditional bit a little differently, but didn't have the
time to really look into it today.

Comment 8 Jarod Wilson 2006-11-14 19:13:35 UTC
Okay, just checked a spec into the devel branch that conditionalizes the
building of python, php and tcl bits. Same idea as the attached patch, but
implemented slightly different. Use '--without <component>' to disable bits.
Once built for devel, I'll also check the changes in for FC5 and 6.