Bug 203297

Summary: yelp crashes on some searches xslt
Product: [Fedora] Fedora Reporter: Han-Wen Nienhuys <hanwen>
Component: yelpAssignee: Matthew Barnes <mbarnes>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-01 15:25:23 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Han-Wen Nienhuys 2006-08-20 18:01:15 EDT
Description of problem:

with yelp-2.15.5-1 search for xslt. Crash.

GNU gdb Red Hat Linux (6.5-3.fc6rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

(gdb) r
Starting program: /usr/bin/yelp 
[Thread debugging using libthread_db enabled]
[New Thread -1208396064 (LWP 4547)]
[New Thread -1210496096 (LWP 4550)]

(yelp:4547): Yelp-WARNING **: An error occurred getting the gconf value
'/apps/yelp/variable_font'


(yelp:4547): Yelp-WARNING **: An error occurred getting the gconf value
'/apps/yelp/fixed_font'

[New Thread -1238410336 (LWP 4551)]
[New Thread -1249035360 (LWP 4555)]
[New Thread -1261438048 (LWP 4556)]

(yelp:4547): Yelp-WARNING **: beagled not running, using basic search support.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208396064 (LWP 4547)]
0x4ccbcfe3 in strchr () from /lib/libc.so.6
(gdb) bt
#0  0x4ccbcfe3 in strchr () from /lib/libc.so.6
#1  0x08072002 in slow_search_process (pager=0x9abe9b0) at yelp-search-pager.c:1808
#2  0x41acb5e1 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
#3  0x41acd342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#4  0x41ad031f in g_main_context_check () from /lib/libglib-2.0.so.0
#5  0x41ad06c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#6  0x432973c4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#7  0x08067696 in main (argc=Cannot access memory at address 0x2929
) at yelp-main.c:118
#8  0x4cc69214 in __libc_start_main () from /lib/libc.so.6
#9  0x08051ed1 in _start ()
(gdb) 


in addition, bug-buddy doesn't work for this crash (bug filed with gnome.org)
Comment 1 Matthew Barnes 2006-09-01 15:06:39 EDT
I haven't been able to reproduce this on yelp-2.15.91-3.fc6.

It notice that you didn't have a "beagled" process running, which is probably
significant.  So I made sure there was no "beagled" process when I tried it.

Can you try this again with the latest Rawhide package?
Comment 2 Han-Wen Nienhuys 2006-09-01 15:25:23 EDT
works for me now on yelp-2.15.91-2