Bug 2033265

Summary: Knative Services and Revisions are not shown when Service has no ownerReference
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Dev ConsoleAssignee: Christoph Jerolimov <cjerolim>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.10CC: aos-bugs, nmukherj
Target Milestone: ---   
Target Release: 4.9.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-01-31 18:22:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2032831    
Bug Blocks:    

Description OpenShift BugZilla Robot 2021-12-16 11:56:14 UTC
+++ This bug was initially created as a clone of Bug #2032831 +++

Description of problem:
Knative Services and Revisions are not shown if the Service has no metadata.ownerReference attribute.

There is a browser error logged but the topology shows no error. Just the Knative services are shown just as deployments.

  ModelContext.ts:179 Unable to add some resources to topology TypeError: Cannot read properties of undefined (reading '0')
    at get-knative-resources.ts:62
    at arrayFilter (_arrayFilter.js:18)
    at Module.filter (filter.js:49)
    at getRevisions (get-knative-resources.ts:61)
    at getKnativeServingRevisions (get-knative-resources.ts:88)
    at knative-topology-utils.ts:486
    at Array.reduce (<anonymous>)
    at getKnativeServiceData (knative-topology-utils.ts:485)
    at createKnativeDeploymentItems (knative-topology-utils.ts:530)
    at knative-topology-utils.ts:1043

Version-Release number of selected component (if applicable):
4.6 shows the Service, but no Revisions in it. No error in the browser console.
4.7-4.10 shows a Deployment instead of the Service/Revision and an error in the browser console.

How reproducible:
Always on my local cluster, but don't know yet how to reproduce this.

Steps to Reproduce:
Sorry, not clear. Just have some Services without metadata.ownerReference. Tried to reproduce but wasn't lucky.

Actual results:
Error is logged in the browser console and Knative Services and Revisions entries are shown as Deployment. See attached screenshot.

Expected results:
No error in the browser console and I want to see my Knative Services and Revisions again. :)

Additional info:

Comment 4 Christoph Jerolimov 2022-01-26 11:21:23 UTC
Not clear how to reproduce this. Tested Serverless components on 4.9.0-0.ci-2022-01-26-040531 and everything works as expected.

Comment 6 errata-xmlrpc 2022-01-31 18:22:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0279