Bug 2034759

Summary: rust-image-roll-1.4.0 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: rust-image-rollAssignee: RĂ©mi Lauzier <remilauzier>
Status: CLOSED ERRATA QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: remilauzier, rust-sig
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rust-image-roll-1.4.0-1.fc36 rust-image-roll-1.4.0-1.fc35 Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-12-22 04:31:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Upstream Release Monitoring 2021-12-22 00:03:52 UTC
Latest upstream release: 1.4.0
Current version/release in rawhide: 1.3.1-3.fc36
URL: https://crates.io/crates/image-roll

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/214403/

Comment 1 Upstream Release Monitoring 2021-12-22 00:03:57 UTC
Scratch build failed. Details bellow:

BuilderException: Build started, but failure happened during post build operations:
Command '['git', 'commit', '-a', '-m', 'Update to 1.4.0 (#2034759)']' returned non-zero exit status 1.

StdOut:
On branch rawhide
Your branch is up to date with 'origin/rawhide'.

Untracked files:
  (use "git add <file>..." to include in what will be committed)
	SRPMS/

nothing added to commit but untracked files present (use "git add" to track)


Traceback:
  File "/usr/local/lib/python3.9/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 226, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2021-12-22 00:24:48 UTC
the-new-hotness/release-monitoring.org's scratch build of rust-image-roll-1.3.1-1.fc34.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=80304266

Comment 3 Fedora Update System 2021-12-22 04:28:47 UTC
FEDORA-2021-27c214861a has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2021-27c214861a

Comment 4 Fedora Update System 2021-12-22 04:31:12 UTC
FEDORA-2021-27c214861a has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 5 Fedora Update System 2021-12-22 07:02:56 UTC
FEDORA-2021-bcf220eda4 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-bcf220eda4

Comment 6 Fedora Update System 2021-12-23 01:43:02 UTC
FEDORA-2021-bcf220eda4 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-bcf220eda4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-bcf220eda4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-12-31 01:20:28 UTC
FEDORA-2021-bcf220eda4 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.