Bug 203535

Summary: tail: cannot open `+n' for reading: No such file or directory
Product: [Fedora] Fedora Reporter: Ehringer Eike <ehringer.eike>
Component: coreutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 5CC: meyering
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-22 09:16:53 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ehringer Eike 2006-08-22 07:40:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)

Description of problem:
When doing:
# tail +n 2 su.log
tail: cannot open `+n' for reading: No such file or directory
tail: cannot open `2' for reading: No such file or directory



Version-Release number of selected component (if applicable):
coreutils-5.96-1.2.x86_64.rpm

How reproducible:
Always


Steps to Reproduce:
1. tail +n Number File
tail: cannot open `+n' for reading: No such file or directory
tail: cannot open `Number' for reading: No such file or directory

Actual Results:
nothing

Expected Results:
Refere to manual pages of tail:
# man tail
If the first character of N (the number of bytes or lines) is a +, print beginning  with  the  Nth  item from  the start of each file, otherwise, print the last N items in the file.

Additional info:
The tail command is not doing the expected result, which is described in the manual pages. Also on FC4 with e.g. coreutils-5.2.1-48.1.x86_64.rpm
-> tail +n is working.
Also on every HP-UX, AIX, SUN Solaris, RedHat Advanced Server, Enterprise systems the tail is working with +N.

-> So youre administrative management tools / and scripts does not work anymore!
Comment 1 Tim Waugh 2006-08-22 09:16:53 EDT
> tail +n 2 su.log

I think you meant:

  tail -n +2 su.log
Comment 2 Tim Waugh 2006-08-22 09:18:08 EDT
*** Bug 203537 has been marked as a duplicate of this bug. ***
Comment 3 Ehringer Eike 2006-08-23 01:48:52 EDT
Good morning,
i mean of course: # tail +2 su.log

e.g.:
# uname -a
HP-UX rbgs420x B.11.11 U 9000/800 1798937691 unlimited-user license

rooteieh:root @ IgniteSrv on rbgs420x  from RBG0J26C.ww011.siemens.net: 1812 
[ /tmp ]
# tail +2 vginfo.txt


e.g.
# tail +2 su.log
tail: cannot open `+2' for reading: No such file or directory
Comment 4 Tim Waugh 2006-08-23 04:35:59 EDT

*** This bug has been marked as a duplicate of 173431 ***
Comment 5 Ehringer Eike 2006-08-24 05:38:13 EDT
which is now the dublicate bug an what the real?
could you please mark one as GOOD - WORKING ONE?

thanks!