Bug 2037245

Summary: Consider renaming minizip to minizip-ng and minizip-compat to minizip to match upstream naming
Product: [Fedora] Fedora Reporter: Honza Horak <hhorak>
Component: minizipAssignee: Lukas Javorsky <ljavorsk>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 36CC: hhorak, ljavorsk, Neustradamus, odubaj, panovotn
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-11-04 14:30:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2129079    
Bug Blocks:    

Description Honza Horak 2022-01-05 10:38:30 UTC
Description of problem:

Today in Fedora, we have minizip-compat-1.2.x (coming from zlib component) and minizip-3.0.x (a separate component which is actually minizip-ng in upstream).

There is a discussion on github about what names for those projects are best to use, so once there is a conclusion, this bug is supposed to track the changes done in Fedora.

https://github.com/zlib-ng/minizip-ng/issues/358

Comment 1 Fedora Admin user for bugzilla script actions 2022-01-11 12:22:21 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 2 Neustradamus 2022-01-28 13:00:19 UTC
Hello all,

Thanks @hhorak for this ticket :)

Since a moment, it is really clear, original code/place and NG code/place.

To have a perfect compatibility with all, to do not break and do not mix, the goal is to have (like other distos):
- zlib
- minizip

and NG versions:
- zlib-ng
- minizip-ng

Original code is always developed, you can see here:

zlib master branch:
- https://github.com/madler/zlib/
- https://github.com/madler/zlib/tree/master/contrib/minizip

zlib develop branch:
- https://github.com/madler/zlib/tree/develop
- https://github.com/madler/zlib/tree/develop/contrib/minizip

Specified by @hhorak, you can see talk here:
- https://github.com/zlib-ng/minizip-ng/issues/358

Thanks a lot in advance.

PS: There are release updates.

Comment 3 Ben Cotton 2022-02-08 20:27:09 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.

Comment 4 Honza Horak 2022-03-14 14:02:30 UTC
Clearing needinfo, it's not clear what the info missing was here. Anyway, leaving the next action on the Matej, the assignee.

Comment 5 Lukas Javorsky 2022-08-10 07:46:14 UTC
The Fedora change was created for this.
https://fedoraproject.org/wiki/Changes/MinizipRenaming

Comment 6 Lukas Javorsky 2022-09-15 10:42:29 UTC
I'll lead this change and use this BZ as a tracker for the progress along the way

Comment 7 Lukas Javorsky 2022-09-21 10:58:10 UTC
The change has been edited and we will rename only the existing "minizip" package to "minizip-ng".

The reason for this is located here: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/FGDEEHM4YANBZUCJIET4LXV2Z34IHBQ5/

Comment 8 Lukas Javorsky 2022-11-04 14:30:49 UTC
This change has been successfully finished.

More is tracked in the BZ#2129079