Bug 2037499

Summary: CNO: verify job is broken since yaml-patch has disappeared
Product: OpenShift Container Platform Reporter: Maysa Macedo <mdemaced>
Component: NetworkingAssignee: Maysa Macedo <mdemaced>
Networking sub component: openshift-sdn QA Contact: zhaozhanqi <zzhao>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: bbennett, zzhao
Version: 4.9   
Target Milestone: ---   
Target Release: 4.9.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 2037496
: 2037500 (view as bug list) Environment:
Last Closed: 2022-01-24 16:50:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2037496    
Bug Blocks: 2037500    

Description Maysa Macedo 2022-01-05 18:24:10 UTC
+++ This bug was initially created as a clone of Bug #2037496 +++

Description of problem:

The verify job has been failing reporting the following message:
 mkdir -p '_output/tools/bin/'
curl -s -f -L https://github.com/krishicks/yaml-patch/releases/download/v0.0.10/yaml_patch_linux -o '_output/tools/bin/yaml-patch'
make: *** [ensure-yaml-patch] Error 22 

This is happening because yaml-patch no long exists. To fix it the build-machinery-go dependency needs to be bumped since it already fixed[1] the issue.

[1] https://github.com/openshift/build-machinery-go/pull/58

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 zhaozhanqi 2022-01-14 10:45:49 UTC
Verified this bug on 4.9.0-0.nightly-2022-01-14-003615

Comment 6 errata-xmlrpc 2022-01-24 16:50:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0195