Bug 2037933

Summary: Please branch and build R in epel9
Product: [Fedora] Fedora EPEL Reporter: neil
Component: RAssignee: Tom "spot" Callaway <spotrh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel9CC: i.ucar86, orion, spotrh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: R-4.1.2-1.el9 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-01-30 01:15:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description neil 2022-01-06 21:07:04 UTC
Please branch and build R in epel9

Comment 1 Orion Poplawski 2022-01-07 03:48:09 UTC
Looks like a branch was created.  My scratch build failed on x86_64 with:

+ make check
make[1]: Entering directory '/builddir/build/BUILD/R-4.1.2/tests'
make[2]: Entering directory '/builddir/build/BUILD/R-4.1.2/tests'
make[3]: Entering directory '/builddir/build/BUILD/R-4.1.2/tests/Examples'
Testing examples for package 'base'
Error: testing 'base' failed
Execution halted

which isn't very informative.  Presumably it's being looked into?

FWIW, I need this for picosat.  Thanks Spot.

Comment 2 Orion Poplawski 2022-01-08 03:45:02 UTC
Looks like LTO needs to be disabled on EL9+ as well as Fedora 36+ due to an issue with double complex.  Spot - should I go ahead and do this?

Comment 3 IƱaki Ucar 2022-01-10 10:13:39 UTC
This was already done for Fedora 36+ in [1]. You just need to "fix" that switch to consider EL9+ too, so I'd say go ahead.

[1] https://src.fedoraproject.org/rpms/R/c/c236b87ba9b7b7cd7ca3483c557a06ea965dbe29?branch=rawhide

Comment 4 Fedora Update System 2022-01-11 02:54:00 UTC
FEDORA-EPEL-2022-5eb4de292b has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-5eb4de292b

Comment 5 Tom "spot" Callaway 2022-01-11 21:05:43 UTC
Orion, thanks for taking this. I requested the branch and promptly got buried at work. :/ Nice work.

Comment 6 Fedora Update System 2022-01-12 02:10:44 UTC
FEDORA-EPEL-2022-5eb4de292b has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-5eb4de292b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Orion Poplawski 2022-01-12 03:57:00 UTC
Happy to help.  Looks like we now neeed R-rpm-macros - see bug #2039606

Comment 8 Fedora Update System 2022-01-30 01:15:55 UTC
FEDORA-EPEL-2022-5eb4de292b has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.