Bug 2038936

Summary: Change cluster version operator log level
Product: OpenShift Container Platform Reporter: Scott Dodson <sdodson>
Component: Cluster Version OperatorAssignee: Jack Ottofaro <jack.ottofaro>
Status: CLOSED ERRATA QA Contact: Evgeni Vakhonin <evakhoni>
Severity: medium Docs Contact:
Priority: low    
Version: 4.8CC: aos-bugs, evakhoni, jack.ottofaro, jiajliu, sdodson, wking, yaoli
Target Milestone: ---Keywords: Reopened
Target Release: 4.8.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 2038275 Environment:
Last Closed: 2022-01-25 12:13:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2038275    
Bug Blocks:    

Comment 3 Evgeni Vakhonin 2022-01-12 10:33:11 UTC
using the same method as #2034493

Reproduced
Cluster version is 4.8.0-0.nightly-2022-01-11-000651

# oc -n openshift-cluster-version get deployment cluster-version-operator -oyaml|grep -e "--v"
        - --v=5

# oc logs -n openshift-cluster-version cluster-version-operator-857fcd9c85-c9zkc |grep "I0112 09:[0-5][0-9]" > cvo-old.log
# ls -l cvo-old.log
-rw-r--r--. 1 evakhoni evakhoni 6368415 Jan 12 12:24 cvo-old.log

# grep "due to client-side throttling" cvo-old.log |wc -l 
9019



Verified
Cluster version is 4.8.0-0.nightly-2022-01-12-034645

# oc -n openshift-cluster-version get deployment cluster-version-operator -oyaml|grep -e "--v"
        - --v=2

# oc logs -n openshift-cluster-version cluster-version-operator-796b999cf6-jvlm4 |grep "I0112 09:[0-5][0-9]" > cvo-new.log
# ls -l cvo-new.log 
-rw-r--r--. 1 evakhoni evakhoni 4261636 Jan 12 12:25 cvo-new.log

# grep "due to client-side throttling" cvo-new.log |wc -l
0

log size reduced by 33.0%

Comment 6 errata-xmlrpc 2022-01-25 12:13:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.28 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0172