Bug 2039843 (CVE-2022-0156)

Summary: CVE-2022-0156 vim: use-after-free while treating allocated lines in user functions
Product: [Other] Security Response Reporter: Marian Rehak <mrehak>
Component: vulnerabilityAssignee: Nobody <nobody>
Status: NEW --- QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: bdettelb, caswilli, dhalasz, fhrdina, fjansen, gchamoul, jburrell, jwong, karsten, kaycoth, micjohns, sthirugn, vkrizan, vkumar, vmugicag, zdohnal
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: vim 8.2.4040 Doc Type: If docs needed, set a value
Doc Text:
It was found that vim was vulnerable to use-after-free flaw in the way it was treating allocated lines in user functions. A specially crafted file could crash the vim process or possibly lead to other undefined behaviors.
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2039845, 2040253, 2043462    
Bug Blocks: 2039688    

Comment 1 Marian Rehak 2022-01-12 14:29:36 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2039845]

Comment 3 Cedric Buissart 2022-01-13 10:18:05 UTC
Vim versions prior to 8.2 do not seem to be vulnerable to this flaw

Comment 5 Cedric Buissart 2022-01-14 15:57:47 UTC
The flaw was introduced in v8.2.3902. Older versions are not impacted by this flaw.