Bug 2040657

Summary: glibc: More reliable CPU compatibility diagnostics
Product: Red Hat Enterprise Linux 9 Reporter: Florian Weimer <fweimer>
Component: glibcAssignee: Florian Weimer <fweimer>
Status: CLOSED ERRATA QA Contact: Sergey Kolosov <skolosov>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 9.0CC: ashankar, codonell, dj, fweimer, gkurz, mnewsome, pfrankli, sipoyare
Target Milestone: rcKeywords: Bugfix, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glibc-2.34-20.el9 Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-17 15:48:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Deadline: 2022-02-07   

Description Florian Weimer 2022-01-14 11:38:47 UTC
This is prompted by bug 2035158, which shows that we have regressed the diagnostics for running RHEL 9 on POWER8.

I think we need to fix this properly, changing the compiler flags for early startup.

Comment 2 Florian Weimer 2022-01-14 12:45:19 UTC
Patches posted upstream:

[PATCH 0/7] Reliable CPU compatibility diagnostics in ld.so
https://sourceware.org/pipermail/libc-alpha/2022-January/135291.html

Comment 9 errata-xmlrpc 2022-05-17 15:48:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (new packages: glibc), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:3917