Bug 20469

Summary: kdelibs (KDE2) doesn't include docs
Product: [Retired] Red Hat Linux Reporter: Need Real Name <volker>
Component: kdelibsAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-11-08 15:01:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2000-11-07 14:35:44 UTC
kdelibs-2.0-7.i386.rpm from ftp.kde.org does not include the KDE documentation (/usr/share/doc/HTML/*)

Comment 1 Bernhard Rosenkraenzer 2000-11-08 08:24:13 UTC
Oops, the fixed kdoc wasn't installed on the build server.
The spec file is ok, so simply recompiling this on a system with a working kdoc fixes the problem.
The Red Hat Linux 7 version fixes the problem, too.

Comment 2 Need Real Name 2000-11-08 15:01:18 UTC
I've recompiled the package, the docs are still not included. I suggest adding

%dir %{prefix}/share/doc
%{prefix}/share/doc/*

to the %files section of the main package to include the doc files under /usr/share/doc/HTML/*

Comment 3 Bernhard Rosenkraenzer 2000-11-08 15:45:29 UTC
Oh, the main package.
It's not supposed to contain the docs.

Since the docs in kdelibs are about the API (programming the libraries), the right place for the docs is in kdelibs-devel, and they're there.