Bug 2050290

Summary: lua: typo on man page
Product: [Fedora] Fedora Reporter: Jerry James <loganjerry>
Component: luaAssignee: Tom "spot" Callaway <spotrh>
Status: NEW --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 35CC: 4le, drjohnson1, lua-packagers-sig, mhroncok, michel, rob.myers, spotrh
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jerry James 2022-02-03 16:05:23 UTC
Description of problem:
The man page says (in part):

LUA_PATH, LUA_PATH_5_4
       Initial value of package.cpath, the path used by require to search for Lua loaders.

That should be package.path, not package.cpath.  This caused me a minute or so of confusion. :-)

Version-Release number of selected component (if applicable):
lua-5.4.3-4.fc35.x86_64

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Miro HronĨok 2022-02-03 16:27:06 UTC
I was like: that should be easy to fix, let's send them a pull request upstream. But apparently, they use mailing lists to do that, so I'll pass :(