This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 205148

Summary: xenguest-install is hardcoded to use xenbr0 on installation
Product: [Fedora] Fedora Reporter: Sam Folk-Williams <sfolkwil>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: bstein, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: python-virtinst-0.98.0-1.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-01-11 16:39:17 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 150223    

Description Sam Folk-Williams 2006-09-04 16:52:08 EDT
Description of problem:
On systems where eth0 is not the primary interface, the installation of a guest
OS will fail due to the fact that no network driver can be found. This is caused
by the fact that the xen bridge device is named based on the primary ethX
device, and xenguest-install is hardcoded to use senbr0. On my system eth0 is
not plugged in, and eth2 is the primary device. The xen bridge is therefore
named xenbr2, and xenguest-install can't see it.

Version-Release number of selected component (if applicable):
[root@localhost ~]# rpm -qa | grep xen
python-xeninst-0.92.0-1
kernel-xen-2.6.17-1.2614.fc6
kernel-xen-2.6.17-1.2517.fc6
xen-libs-3.0.2-29
xen-3.0.2-29


How reproducible:
Always

Steps to Reproduce:
1. Boot up the system with eth0 unplugged and another ehtX device plugged in
2. Try to install via xenguest-install or virt-manager
3. guest OS Installer will fail to bring up network device
  
Actual results:
guest OS Installer will fail to bring up network device

Expected results:
Guest OS installer should find the network device

Additional info:
To workaround, use can modify /etc/xen/xend-config.sxp as follows:

Change the network-script line to:

(network-script 'network-bridge bridge=xenbr0')

Reboot.
Comment 1 Jeremy Katz 2006-09-04 17:19:42 EDT
You can pass another bridge by using '-b foo' where foo is the other bridge you
want to use.  Not sure if this is really auto-detectable.
Comment 2 Sam Folk-Williams 2006-09-05 11:24:13 EDT
But what if you are using the GUI (virt-manager) - can't pass the option with
that i don't think.

Thanks,
Sam
Comment 3 Jeremy Katz 2006-09-05 13:18:50 EDT
virt-manager can also set the appropriate bits.  The problem is that asking is
almost definitely wrong (as no one is going to be able to answer this) so we
really need to figure out a way to either auto-detect this or fix it so that we
don't have to
Comment 4 Daniel Berrange 2007-01-11 16:39:17 EST
python-virtinst will now automatically detect the correct primary bridge device
based on the defualt route.