Bug 2052922 (CVE-2022-0534)

Summary: CVE-2022-0534 htmldoc: stack out-of-bounds read in gif_get_code() when opening a malicious GIF file results in a segmentation fault
Product: [Other] Security Response Reporter: Vipul Nair <vinair>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED UPSTREAM QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: extras-orphan, rdieter
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-02-10 10:22:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2052924    
Bug Blocks:    

Description Vipul Nair 2022-02-10 09:51:15 UTC
A vulnerability was found in htmldoc version 1.9.15 where the stack out-of-bounds read takes place in gif_get_code() and occurs when opening a malicious GIF file, which can result in a crash (segmentation fault).

https://github.com/michaelrsweet/htmldoc/commit/312f0f9c12f26fbe015cd0e6cefa40e4b99017d9
https://github.com/michaelrsweet/htmldoc/issues/463

Comment 1 Vipul Nair 2022-02-10 09:54:58 UTC
Created htmldoc tracking bugs for this issue:

Affects: fedora-all [bug 2052924]

Comment 2 Product Security DevOps Team 2022-02-10 10:22:55 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.