Bug 205864

Summary: USB hard drive invisible at boot
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-25 08:05:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tom Horsley 2006-09-08 22:44:36 EDT
Description of problem:

On FC5, when I boot /dev/sdc5 shows up pointing to my external USB
hard drive, on FC6t2 with latest updates, there is no USB drive
in /dev/ when I boot - I have to unplug and plug back in for it to
show up (at which point I do see /dev/sdc5 just as in FC5).

Version-Release number of selected component (if applicable):

Aug 29 19:12:07 (yumex) Updated: udev.x86_64 095-8
Sep 01 19:47:44 (yumex) Updated: hal.x86_64
Sep 08 22:00:36 (yumex) Installed: kernel.x86_64 2.6.17-1.2630.fc6
(not sure if any other components might be relevant)

How reproducible:

So far, everytime.

Steps to Reproduce:
1. boot system
2. see no /dev/sdc5
Actual results:

no disk device

Expected results:

disk device

Additional info:

I see the closed bug 201422 which implies that the additional rule fixes
problems like this, however, I checked my 05-udev-early.rules file and
it does indeed contain the rule 201422 talks about (it fact it is identical
with the FC5 version of the file), so whatever is going on wasn't fixed
by 201422.

This is a 500GB Maxtor USB 2.0 drive in case it matters.

On my FC5 system, I see this in the /var/log/dmesg file which appears
to have something to do with the USB hard drive:

ohci_hcd 0000:00:02.0: wakeup
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning

On FC6t2, I see nothing in the dmesg file that gives any hint that
it has anything to do with the USB drive (and certainly none of the
messages above show up in any form).
Comment 1 Tom Horsley 2006-09-15 21:29:15 EDT
Just installed FC6t3 and worked through a bunch of problems to get it where
it would boot, and found that the initial install from the DVD image has the
same problem with not recognizing USB hard drive.

However, once I ran yum and pulled in all the latest updates which got me to
the 2647 kernel, it does recognize the USB disk, so it looks like this is
probably fixed in latest devel versions.