Bug 2062133

Summary: Azure VNET lookup fails when the NIC subnet is in a different resource group
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: NetworkingAssignee: Casey Callendrello <cdc>
Networking sub component: openshift-sdn QA Contact: Mike Fiedler <mifiedle>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: cdc, mifiedle, travi
Version: 4.10Keywords: ServiceDeliveryImpact
Target Milestone: ---   
Target Release: 4.10.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-04-25 19:51:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2060334    
Bug Blocks:    

Comment 4 Mike Fiedler 2022-04-20 19:12:36 UTC
Verified on the 4.10.11 candidate.   Upgraded 4.9.z latest to 4.10.11.   After upgrade the egress annotation is present on the node.

# oc get infrastructures.config.openshift.io cluster  -ojsonpath='{.status.platformStatus}' | jq 
{
  "azure": {
    "cloudName": "AzurePublicCloud",
    "networkResourceGroupName": "mffiedler420a-rg",
    "resourceGroupName": "mffiedler420a-7ftbt-rg"
  },
  "type": "Azure"
}

  annotations:
    cloud.network.openshift.io/egress-ipconfig: '[{"interface":"mffiedler420a-7ftbt-worker-northcentralus-lrw4w-nic","ifaddr":{"ipv4":"10.0.0.0/16"},"capacity":{"ip":255}}]'

Comment 6 errata-xmlrpc 2022-04-25 19:51:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:1431