Bug 2062501

Summary: Please build swtpm for epel 8
Product: [Fedora] Fedora Reporter: Paul Maidment <pmaidmen>
Component: swtpmAssignee: Stefan Berger <stefanb>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: carl, dcavalca, ddepaula, jen, marcandre.lureau, odepaz, stefanb
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: swtpm-0.5.4-1.20220310git36cf9da.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-03-18 20:24:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Maidment 2022-03-09 23:43:51 UTC
Description of problem:

Version 0.5.3 fixes a bug that was registered here https://github.com/stefanberger/swtpm/issues/644

We want to update our service to make use of this change.

So we are requesting that swtpm be built for epel 8.

Comment 1 Stefan Berger 2022-03-10 01:28:25 UTC
Can I build swtpm 0.7.2 or does it have to be the older 0.5.x?

Comment 2 Osher De Paz 2022-03-10 07:51:58 UTC
The reason for the request of 0.5.x is that we're using Rocky Linux and not Fedora, so it needs to use the EPEL repository (which only includes 0.5.x versions for some reason: https://mirrors.xtom.de/epel/8/Everything/x86_64/Packages/s/

If it's possible to upload 0.7.x versions there, I'm not sure we'll mind. I just assumed it has to do something with the other packages compatibility

Comment 3 Stefan Berger 2022-03-10 12:10:01 UTC
I am asking for the version so that this can be coordinated with what RHEL 8.x is packaging these days.

Comment 4 Osher De Paz 2022-03-10 12:14:21 UTC
So AFAIK, 0.5.x is the right thing to release for centos/rhel/rocky/etc.
I'm an openshift engineer though, not an OS one

Comment 5 Fedora Update System 2022-03-10 13:45:12 UTC
FEDORA-EPEL-2022-d8fc98dbc3 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-d8fc98dbc3

Comment 6 Marc-Andre Lureau 2022-03-10 14:22:58 UTC
(In reply to Osher De Paz from comment #4)
> So AFAIK, 0.5.x is the right thing to release for centos/rhel/rocky/etc.
> I'm an openshift engineer though, not an OS one

Hi,

RHEL 8.6 swtpm version will be 0.7.0-1.20211109gitb79fd91.

RHEL 8.5 (AV) should be 0.6.0-2.20210607gitea627b3.

But EPEL should not provide conflicting packages with RHEL, so swtpm & libtpms should be retired I suppose.

wdyt Danilo?

Comment 7 Carl George 🤠 2022-03-10 17:22:38 UTC
Correct, when RHEL 8.6 is released (in approximately two months) swtpm and libtpms must be retired from epel8.

I had unpushed this bodhi update because I misunderstood this to be a new package to epel8, which wouldn't make sense to add for only two months.  Then I realized that this package is already in epel8 [0].  At the time it was added it wasn't in violation of policy, as swtpm wasn't part of the virt:rhel module yet.  Considering it's already in epel8, and module filtering hides this package, it won't effect CentOS Stream 8 systems and is probably ok to keep (and update) in epel8 until the RHEL 8.6 release.

[0] https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-d32a6ed9c9

Comment 8 Fedora Update System 2022-03-11 15:57:51 UTC
FEDORA-EPEL-2022-d8fc98dbc3 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-d8fc98dbc3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-03-18 20:24:46 UTC
FEDORA-EPEL-2022-d8fc98dbc3 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.