Bug 206479

Summary: "Edit LVM Volume Group" dialog missing accelerator key
Product: [Fedora] Fedora Reporter: Greg Morgan <drkludge>
Component: anacondaAssignee: Joel Andres Granados <jgranado>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: rawhideCC: drkludge, jgranado, mattdm
Target Milestone: ---Keywords: StringChange
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-02 05:37:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
patch to add the necesary accelerator keys.
patch to add the necesary accelerator keys.
New patch none

Description Greg Morgan 2006-09-14 12:44:29 EDT
Description of problem: The "Edit LVM Volume Group" dialog is missing an
accelerator key.  This is not a problem with mouse driven systems.  However, I
testing the release on an old FIC 501+ that supports only a serial mouse.  All
the other widgets have an accelerator key define.  The section that is missing
one is the "Logical Volumnes" scroll box.  If you touch a VM, once you finishing
the adjustment and click ok, then the screen highlight goes to an inderminate
state.  Compare this with clicking cancel in the same "Edit Logcial Volume" mini
dialog.  If you hit cancel, the "Edit LVM Volume Group" remembers its setting
once the "Edit Logcial Volume" dialog goes away.  

1.) It would be nice if the OK button used the same memory function that the
cancel button does.  However, it is understood that the OK may have to refresh
all the other widgets.

2.) Either way, the "Logical Volumnes" scroll list needs, say, the L used as an
accelerator to enter into the box.

3.) I did note that the up and down arrows do not act consitantly in the
"Logical Volumnes" dialog either as I was writing up this bug report.  It is
understood that the "Physical Extent" should use the up and down arrows.  Once
the user has tabbed out of that field, then both the up and down arrows should
follow the tab flow of the screen.  On several of the widgets, that arrows are
dead in the water.

Version-Release number of selected component (if applicable): FC6 test2

How reproducible:
Appears missing all the time.

Steps to Reproduce:
1. Click (tab to) on the box to customize default disk partition layout.
2. Down arrow to a volumn.
3. Click (alt E) to edit the selected partition.
4. The work around is that you have to tab to get to the desired "Logical Volume
Actual results:
Have to tabe to the "Logical Volumnes" scroll list.

Expected results:
Alt L takes me to the "Logical Volumnes" scroll list along with arrow keys
working properly verses inconsistantly.
Comment 2 Joel Andres Granados 2007-03-29 11:44:58 EDT
Created attachment 151206 [details]
patch to add the necesary accelerator keys.

With regards to the comments:
1)I might be missing something, regarding the tab state after the ok or cancel
button, the gui presents the same behavior.

2)fixed the patch is attached.

3)I might be missing something here as well.  I see the behavior just fine. 
When I hit tab the focus is forwarded from widget to widget. Also, only in the
"physical extent" drop down menu do the "up-down" kees allow me to navagate
inside the widget (this being the correct behavior).  And in the "Physical
Volumes to use" it is also possible to navigate with the "up-down" kees (also
correct behavior).  Moreover, when the focus is not on these two widgets the
"up-down" kesy also allow to change the focus of the widgets.
Comment 3 Joel Andres Granados 2007-03-29 11:49:38 EDT
Created attachment 151208 [details]
patch to add the necesary accelerator keys.

The previos diff was a bit strange.  this one is better.
Comment 4 Matthew Miller 2007-04-06 15:56:55 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 5 Jeremy Katz 2007-04-09 11:00:07 EDT
(In reply to comment #3)
> Created an attachment (id=151208) [edit]
> patch to add the necesary accelerator keys.
> The previos diff was a bit strange.  this one is better.

This patch removes the bold formatting as well as the translations.  Also, we're
too late to add a mnemonic at this point as it would break the string freeze.
Comment 6 Joel Andres Granados 2007-04-11 11:28:45 EDT
Created attachment 152283 [details]
New patch

Revisited the patch and made a some modifications that I think address comment
The Bold is maintained ant the mnemonic is present.  
I couldn't test if the language was still present because that would mean
changing the PO files and I don't know how to do this exactly :(.  I did some
trials with no success.  Anyone know how to test the po files here.  Im pretty
sure that it has something to do with MO files but I just wasn't able to put
them in the installer.
Looking at the code Im pretty confident that it will behave as expected.

Regarding the string freeze,  IMO its best to leave it for next release. 
Additionally the PO files must be changed, so that would take some additional
Comment 7 Greg Morgan 2007-09-06 03:37:36 EDT
Thank you for all the work that has gone into this bug report.