Bug 206504

Summary: Locales do not work, useless po files installation
Product: [Fedora] Fedora Reporter: Lubos Stanek <lubek>
Component: gdeskcalAssignee: Paul F. Johnson <paul>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: extras-qa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-11-02 22:09:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 213321    

Description Lubos Stanek 2006-09-14 19:07:25 UTC
Description of problem:
Locales do not work
The po files installation is useless.

Version-Release number of selected component (if applicable):
0.57.1-5 and backwards

How reproducible:
Run with non-US settings or with changed LANG=.

Actual results:
Always in C (default en) because locales were not found.

Expected results:
It should run in many locales.

Additional info:
From values.py:
SYSTEMLOCALEDIR = "LOCALEDIR"
LOCALEDIR = "locale"
From i18n.py:
localedir=os.environ.get(values.SYSTEMLOCALEDIR, values.LOCALEDIR)
gettext.install("gdeskcal", localedir, unicode = 1)

The environment variale LOCALEDIR does not exist on most systems, therefore the
"locale" directory path is always returned.

Solution:
Replace os.environ.get() function or remove it and provide direct path in:
gettext.install("gdeskcal", "/usr/share/locale", unicode = 1). Or test the
presence of the local "locale" directory, otherwise use system default.

Comment 1 Paul F. Johnson 2006-11-02 22:09:16 UTC
Fixed in 1.0