Bug 2065588

Summary: glibc: Multithreaded process crash when calling popen() [rhel-8.7.0]
Product: Red Hat Enterprise Linux 8 Reporter: Takayuki Nagata <tnagata>
Component: glibcAssignee: Carlos O'Donell <codonell>
Status: CLOSED ERRATA QA Contact: Martin Coufal <mcoufal>
Severity: medium Docs Contact: Jacob Taylor Valdez <jvaldez>
Priority: unspecified    
Version: 8.4CC: ashankar, codonell, dj, fweimer, jvaldez, mcoufal, mnewsome, pfrankli, sipoyare, skolosov
Target Milestone: rcKeywords: Bugfix, Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: glibc-2.28-198.el8 Doc Type: Bug Fix
Doc Text:
.`popen()` no longer causes multithreaded processes to crash Previously, a defect in `popen()` caused applications to crash when using the interface from a multithreaded process. With this update, the bug has been fixed and multithreaded processes no longer crash when using `popen()`.
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-11-08 10:43:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Comment 21 errata-xmlrpc 2022-11-08 10:43:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (glibc bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7684