Bug 2066771

Summary: Insights Advisor widget is not in the disabled state when the Insights Operator is disabled
Product: OpenShift Container Platform Reporter: Georgii Karataev <gkaratae>
Component: Insights OperatorAssignee: Georgii Karataev <gkaratae>
Status: CLOSED ERRATA QA Contact: ireyes
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.10CC: aos-bugs, inecas, mklika, tremes
Target Milestone: ---   
Target Release: 4.9.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-03 07:35:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2039868    
Bug Blocks:    

Description Georgii Karataev 2022-03-22 13:05:02 UTC
Once administrators have opted out of remote health reporting and disabled Insights Operator for their cluster (removing the "cloud.openshift.com" token from the pull-secret - see https://docs.openshift.com/container-platform/4.9/support/remote_health_monitoring/opting-out-of-remote-health-reporting.html), the Prometheus query

"cluster_operator_conditions{name="insights", condition="Disabled"}"

results in `1` (true), which means that the Insights Operator is disabled.

However, the Insights Advisor widget in the main dashboard still shows Insights rule results in the main dashboard for some time. The Insights Advisor widget must consume this Prometheus metric to learn whether Insights Operator is disabled and show the "Disabled" message as long as the Prometheus query results in 1 (true).

Comment 5 errata-xmlrpc 2022-05-03 07:35:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.31 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:1605