Bug 2068203

Summary: Samples not visible in WebConsole in a disconnected cluster
Product: OpenShift Container Platform Reporter: Andy Bartlett <andbartl>
Component: Dev ConsoleAssignee: Christoph Jerolimov <cjerolim>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.9CC: aos-bugs, cjerolim, dperaza, nmukherj, sburke, snetting
Target Milestone: ---   
Target Release: 4.9.z   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-06-30 05:31:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2024262    
Bug Blocks:    

Description Andy Bartlett 2022-03-24 16:23:43 UTC
Description of problem:

My customer has the following issue:

My customer upgraded their first cluster from OCP 4.8.20 to 4.9.23, they are not sure whether the issue already existed before the upgrade or not so not sure if this is related to the upgrade or not, but after the upgrade they noticed that in the WebConsole UI > Developer perspective there are no samples available/visible to add to a project. When they click "View all samples" an empty page is displayed.

The cluster runs disconnected and all sample-images are mirrored to their internal registry. After the upgrade we had to sync some sample-images to their internal registry because they were missing (they saw that in the logs of the cluster-samples-operator pod) and after that they even deleted the pod once to maybe resolve the issue but still no samples are shown.

The openshift-samples operator doesn't generate errors and the as far as we can see everything looks fine, but still no samples are available in the WebConsole.

Version-Release number of selected component (if applicable):

OCP 4.9.23

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Comment 8 Christoph Jerolimov 2022-05-03 22:26:04 UTC
@andbartl Hey Andy, I checked this today on 4.9.23, with a limited user and all samples are shown.

But I can confirm that the page hangs in the loading state if one (of the two) network calls to fetch samples fails for any reason.

Is it possible to check with the customer if there are failing API calls in the browser network inspector? Maybe the customer uses a disconnected cluster?

When this is the case, this is a duplicate of our bug https://bugzilla.redhat.com/show_bug.cgi?id=2024262 that was fixed in 4.10, and we can start a backport of this to 4.9 as well.

Comment 13 Christoph Jerolimov 2022-05-31 13:56:16 UTC
Hi @andbartl, sorry for the delay. I could reproduce this issue now with 4.9.23 (and I can confirm it works in 4.8).

It's also already fixed in 4.10 (and 4.11).

The old issues was logged as https://bugzilla.redhat.com/show_bug.cgi?id=2024262 and https://bugzilla.redhat.com/show_bug.cgi?id=2027288 and should be backported to 4.9 as part of https://bugzilla.redhat.com/show_bug.cgi?id=2029861, but it looks like we missed something in this backport. I will check whats missing and I'm sure we can provide a fix for 4.9 as well.

Comment 16 Christoph Jerolimov 2022-05-31 20:22:14 UTC
The origin PR for 4.10 is https://github.com/openshift/console/pull/10569

The 4.9 backport is now ready for our code review: https://github.com/openshift/console/pull/11616

Comment 23 spathak@redhat.com 2022-06-24 10:50:02 UTC
Verified on build version: 4.9.0-0.nightly-2022-06-23-222249
Browser version: Chrome 101

Comment 25 errata-xmlrpc 2022-06-30 05:31:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.40 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.