Bug 2070020

Summary: InContext doesn't work for Event Sources
Product: OpenShift Container Platform Reporter: Sahil Budhwar <sbudhwar>
Component: Dev ConsoleAssignee: Sahil Budhwar <sbudhwar>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: medium Docs Contact: Olivia Payne <opayne>
Priority: medium    
Version: 4.10CC: cbremble, jakumar, nmukherj, viraj
Target Milestone: ---   
Target Release: 4.11.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: apiVersion in correct format was not passed to resource dropdown in Event source Creation Form. Consequence: Knative Service from InContext is not selected on Resource dropdown in EventSource creation form. Fix: apiVersion in the correct format is passed to the Resource dropdown Result: Resource from InContext is selected in the Resource dropdown.
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-08-10 11:02:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Sahil Budhwar 2022-03-30 09:54:08 UTC
Description of problem:
when connector is dragged from KSVC and EventSource is selected, Incontext doesn't work

Version-Release number of selected component (if applicable):
Serverless Operator


How reproducible:
Always

Steps to Reproduce:
1. Install Serverless Operator
2. Create Knative Service
3. Drag Knative service connector and select Event source option

Actual results: Knative Service is not selected on Resource dropdown in EventSource creation form


Expected results: Knative Service from Incontext should be selected in EventSource creation form


Additional info:

Comment 3 Vikram Raj 2022-04-22 11:50:39 UTC
Verified it on 4.11.0-0.nightly-2022-04-22-002610. And it works as expected.

Comment 6 errata-xmlrpc 2022-08-10 11:02:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Important: OpenShift Container Platform 4.11.0 bug fix and security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2022:5069