Bug 2072135

Summary: [4.10.z] During an IPI install with the 4.10.4 installer on vSphere, getting "Check": platform.vsphere.network: Invalid value: "VLAN_3912": unable to find network provided"
Product: OpenShift Container Platform Reporter: Robert Bost <rbost>
Component: InstallerAssignee: Robert Bost <rbost>
Installer sub component: openshift-installer QA Contact: jima
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: amulmule, crscott, jcallen, jima, padillon, rbost, rcegan, rchaudha, ychoukse
Version: 4.10   
Target Milestone: ---   
Target Release: 4.10.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 2063829 Environment:
Last Closed: 2022-04-25 19:51:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2063829    
Bug Blocks:    

Comment 1 Robert Bost 2022-04-05 17:11:56 UTC
https://github.com/openshift/installer/pull/5773

Comment 2 jima 2022-04-13 07:36:59 UTC
Build image from cluster-bot which includes the fix of installer PR#5773
$ ./openshift-install version
./openshift-install 4.10.0-0.ci.test-2022-04-13-014645-ci-ln-pg5xifb-latest

Verified on QE local env where port is under nested folder and passed.
$ govc ls /Datacenter/network/qetest
/Datacenter/network/qetest/VM Network

$ ./openshift-install create manifests --dir ipi
INFO Consuming Install Config from target directory 
INFO Manifests created in: ipi/manifests and ipi/openshift 
[jima@preserve-wduan-ws 4.10]$ ./openshift-install create cluster --dir ipi
INFO Consuming Worker Machines from target directory 
INFO Consuming OpenShift Install (Manifests) from target directory 
INFO Consuming Openshift Manifests from target directory 
INFO Consuming Master Machines from target directory 
INFO Consuming Common Manifests from target directory 
INFO Obtaining RHCOS image file from 'https://rhcos-redirector.apps.art.xq1c.p1.openshiftapps.com/art/storage/releases/rhcos-4.10/410.84.202201251210-0/x86_64/rhcos-410.84.202201251210-0-vmware.x86_64.ova?sha256=' 
INFO The file was found in cache: /home/jima/.cache/openshift-installer/image_cache/rhcos-410.84.202201251210-0-vmware.x86_64.ova. Reusing... 
INFO Creating infrastructure resources...         
INFO Waiting up to 20m0s (until 7:20AM) for the Kubernetes API at https://api.reliability01a.qe.devcluster.openshift.com:6443... 

Set invalid/empty network:
$ ./openshift-install create cluster --dir ipi
INFO Consuming Worker Machines from target directory 
INFO Consuming Master Machines from target directory 
INFO Consuming Common Manifests from target directory 
INFO Consuming Openshift Manifests from target directory 
INFO Consuming OpenShift Install (Manifests) from target directory 
FATAL failed to fetch Terraform Variables: failed to fetch dependency of "Terraform Variables": failed to generate asset "Platform Provisioning Check": platform.vsphere.network: Required value: must specify the network 

$ ./openshift-install create cluster --dir ipi
INFO Consuming Common Manifests from target directory 
INFO Consuming Openshift Manifests from target directory 
INFO Consuming OpenShift Install (Manifests) from target directory 
INFO Consuming Worker Machines from target directory 
INFO Consuming Master Machines from target directory 
FATAL failed to fetch Terraform Variables: failed to fetch dependency of "Terraform Variables": failed to generate asset "Platform Provisioning Check": platform.vsphere.network: Invalid value: "VM Network QE": unable to find network provided 

Set invalid/empty cluster:
$ ./openshift-install create cluster --dir ipi2
INFO Consuming Master Machines from target directory 
INFO Consuming Openshift Manifests from target directory 
INFO Consuming Worker Machines from target directory 
INFO Consuming Common Manifests from target directory 
INFO Consuming OpenShift Install (Manifests) from target directory 
FATAL failed to fetch Terraform Variables: failed to fetch dependency of "Terraform Variables": failed to generate asset "Platform Provisioning Check": platform.vsphere.cluster: Required value: must specify the cluster 

$ ./openshift-install create cluster --dir ipi2
INFO Consuming Openshift Manifests from target directory 
INFO Consuming OpenShift Install (Manifests) from target directory 
INFO Consuming Master Machines from target directory 
INFO Consuming Common Manifests from target directory 
INFO Consuming Worker Machines from target directory 
FATAL failed to fetch Terraform Variables: failed to fetch dependency of "Terraform Variables": failed to generate asset "Platform Provisioning Check": platform.vsphere.network: Invalid value: "VM Network": could not find vSphere cluster at /Datacenter/host/reliability: cluster '/Datacenter/host/reliability' not found

For upi installation, it's ok to generate manifest/ignition without any error.

Comment 5 jima 2022-04-19 05:22:16 UTC
Based on comment#2, move bug to VERIFIED

Comment 8 errata-xmlrpc 2022-04-25 19:51:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:1431