Bug 2073779

Summary: F36FailsToInstall: Multiple packages built from baresip
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: baresipAssignee: Robert Scheck <redhat-bugzilla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 36CC: redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: baresip-2.0.2-1.fc36 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-07 04:21:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1992487    

Description Miro Hrončok 2022-04-10 12:06:51 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (baresip) Fails To Install in Fedora 36:

can't install baresip:
  - nothing provides libre.so.3()(64bit) needed by baresip-2.0.1-1.fc36.x86_64
  
can't install baresip-aac:
  - nothing provides libre.so.3()(64bit) needed by baresip-aac-2.0.1-1.fc36.x86_64
  
can't install baresip-alsa:
  - nothing provides libre.so.3()(64bit) needed by baresip-alsa-2.0.1-1.fc36.x86_64
  
can't install baresip-av1:
  - nothing provides libre.so.3()(64bit) needed by baresip-av1-2.0.1-1.fc36.x86_64
  
can't install baresip-codec2:
  - nothing provides libre.so.3()(64bit) needed by baresip-codec2-2.0.1-1.fc36.x86_64
  
can't install baresip-ctrl_dbus:
  - nothing provides libre.so.3()(64bit) needed by baresip-ctrl_dbus-2.0.1-1.fc36.x86_64
  
can't install baresip-g722:
  - nothing provides libre.so.3()(64bit) needed by baresip-g722-2.0.1-1.fc36.x86_64
  
can't install baresip-g726:
  - nothing provides libre.so.3()(64bit) needed by baresip-g726-2.0.1-1.fc36.x86_64
  
can't install baresip-gsm:
  - nothing provides libre.so.3()(64bit) needed by baresip-gsm-2.0.1-1.fc36.x86_64
  
can't install baresip-gst:
  - nothing provides libre.so.3()(64bit) needed by baresip-gst-2.0.1-1.fc36.x86_64
  
can't install baresip-gst_video:
  - nothing provides libre.so.3()(64bit) needed by baresip-gst_video-2.0.1-1.fc36.x86_64
  
can't install baresip-gtk:
  - nothing provides libre.so.3()(64bit) needed by baresip-gtk-2.0.1-1.fc36.x86_64
  
can't install baresip-jack:
  - nothing provides libre.so.3()(64bit) needed by baresip-jack-2.0.1-1.fc36.x86_64
  
can't install baresip-mpa:
  - nothing provides libre.so.3()(64bit) needed by baresip-mpa-2.0.1-1.fc36.x86_64
  
can't install baresip-mqtt:
  - nothing provides libre.so.3()(64bit) needed by baresip-mqtt-2.0.1-1.fc36.x86_64
  
can't install baresip-omx:
  - nothing provides libre.so.3()(64bit) needed by baresip-omx-2.0.1-1.fc36.x86_64
  
can't install baresip-opus:
  - nothing provides libre.so.3()(64bit) needed by baresip-opus-2.0.1-1.fc36.x86_64
  
can't install baresip-plc:
  - nothing provides libre.so.3()(64bit) needed by baresip-plc-2.0.1-1.fc36.x86_64
  
can't install baresip-portaudio:
  - nothing provides libre.so.3()(64bit) needed by baresip-portaudio-2.0.1-1.fc36.x86_64
  
can't install baresip-pulse:
  - nothing provides libre.so.3()(64bit) needed by baresip-pulse-2.0.1-1.fc36.x86_64
  
can't install baresip-sdl:
  - nothing provides libre.so.3()(64bit) needed by baresip-sdl-2.0.1-1.fc36.x86_64
  
can't install baresip-snapshot:
  - nothing provides libre.so.3()(64bit) needed by baresip-snapshot-2.0.1-1.fc36.x86_64
  
can't install baresip-sndfile:
  - nothing provides libre.so.3()(64bit) needed by baresip-sndfile-2.0.1-1.fc36.x86_64
  
can't install baresip-v4l2:
  - nothing provides libre.so.3()(64bit) needed by baresip-v4l2-2.0.1-1.fc36.x86_64
  
can't install baresip-vp8:
  - nothing provides libre.so.3()(64bit) needed by baresip-vp8-2.0.1-1.fc36.x86_64
  
can't install baresip-vp9:
  - nothing provides libre.so.3()(64bit) needed by baresip-vp9-2.0.1-1.fc36.x86_64
  
can't install baresip-x11:
  - nothing provides libre.so.3()(64bit) needed by baresip-x11-2.0.1-1.fc36.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-36-x86_64 --disablerepo='*' --enablerepo=local install baresip baresip-aac baresip-alsa baresip-av1 baresip-codec2 baresip-ctrl_dbus baresip-g722 baresip-g726 baresip-gsm baresip-gst baresip-gst_video baresip-gtk baresip-jack baresip-mpa baresip-mqtt baresip-omx baresip-opus baresip-plc baresip-portaudio baresip-pulse baresip-sdl baresip-snapshot baresip-sndfile baresip-v4l2 baresip-vp8 baresip-vp9 baresip-x11


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Update System 2022-04-10 18:05:27 UTC
FEDORA-2022-bb50ddc8db has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-bb50ddc8db

Comment 2 Fedora Update System 2022-05-07 04:21:07 UTC
FEDORA-2022-bb50ddc8db has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.