Bug 2076671

Summary: 4.10: Alibaba Disk CSI driver does not provision small PVCs
Product: OpenShift Container Platform Reporter: Jan Safranek <jsafrane>
Component: StorageAssignee: Jan Safranek <jsafrane>
Storage sub component: Operators QA Contact: Rohit Patil <ropatil>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: ropatil
Version: 4.10   
Target Milestone: ---   
Target Release: 4.10.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Alibaba Cloud supports only Disk volumes larger than 20 GiB. Attempt to dynamically provision a new volume for a PersistentVolumeClaim (PVC) smaller than 20GiB fails and such PVC is Pending forever. Consequence: Small PVCs, created e.g. by a StatefulSet or Helm charts are Pending forever and applications that want to use them can't start. Fix: OpenShift will automatically increase the volume size and it will provision volumes at least with 20 GiB in size. Result: Volumes for small PVCs are dynamically provisioned and applications can start. At the same time, operational costs of such application may increase, as 20GiB volumes are created (and charged for) when an app uses only a fraction of it.
Story Points: ---
Clone Of: 2057495 Environment:
Last Closed: 2022-06-13 14:38:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2057495    
Bug Blocks:    

Comment 11 errata-xmlrpc 2022-06-13 14:38:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:4944