Bug 2078001

Summary: [4.7] Publish RHEL CoreOS AMIs in AWS ap-southeast-3 region
Product: OpenShift Container Platform Reporter: RHCOS Bug Bot <rhcos-bot>
Component: RHCOSAssignee: Michael Nguyen <mnguyen>
Status: CLOSED ERRATA QA Contact: HuijingHei <hhei>
Severity: low Docs Contact:
Priority: unspecified    
Version: 4.11CC: dornelas, jligon, mrussell, nstielau, qzhang
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 2078000 Environment:
Last Closed: 2022-07-14 04:47:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2007087, 2078000    
Bug Blocks:    

Description RHCOS Bug Bot 2022-04-22 19:30:21 UTC
Backport the fix for bug 2077994 to 4.7.

Comment 1 RHCOS Bug Bot 2022-06-09 21:33:45 UTC
This bug has been reported fixed in a new RHCOS build and is ready for QE verification.  To mark the bug verified, set the Verified field to Tested.  This bug will automatically move to MODIFIED once the fix has landed in a new bootimage.

Comment 3 HuijingHei 2022-06-10 00:57:51 UTC
[coreos-assembler]$ kola spawn -d -p aws --aws-type t3.small --aws-ami  ami-0e479f06959488ba8 --aws-region ap-southeast-3
2022-06-10T00:55:54Z cli: Started logging at level DEBUG
2022-06-10T00:55:54Z cli: Started logging at level DEBUG
2022-06-10T00:55:58Z util: WaitUntilReady: checkFunction took 190.147536ms
2022-06-10T00:56:09Z util: WaitUntilReady: checkFunction took 250.346811ms
2022-06-10T00:56:29Z util: RetryUntilTimeout: f() took 20.292886406s
2022-06-10T00:56:51Z util: RetryUntilTimeout: f() took 12.402883039s
2022-06-10T00:56:52Z util: RetryUntilTimeout: f() took 1.089088361s
Red Hat Enterprise Linux CoreOS 47.84.202206091823-0
  Part of OpenShift 4.7, RHCOS is a Kubernetes native operating system
  managed by the Machine Config Operator (`clusteroperator/machine-config`).

WARNING: Direct SSH access to machines is not recommended; instead,
make configuration changes via `machineconfig` objects:
  https://docs.openshift.com/container-platform/4.7/architecture/architecture-rhcos.html

---
[bound] -bash-4.4$ rpm-ostree status
State: idle
Deployments:
* ostree://cbf8a1a0eedaa9637ce92c88249991776152667aa419343b662d469c62b32015
                   Version: 47.84.202206091823-0 (2022-06-09T18:26:24Z)

Comment 4 RHCOS Bug Bot 2022-06-17 15:31:15 UTC
The fix for this bug has landed in a bootimage bump, as tracked in bug 2007087 (now in status MODIFIED).  Moving this bug to MODIFIED.

Comment 6 HuijingHei 2022-06-21 13:14:35 UTC
[coreos-assembler]$ kola spawn -d -p aws --aws-type t3.small --aws-ami ami-05a1827e5adf8c5e3 --aws-region ap-southeast-3

Red Hat Enterprise Linux CoreOS 47.84.202206131038-0
  Part of OpenShift 4.7, RHCOS is a Kubernetes native operating system
  managed by the Machine Config Operator (`clusteroperator/machine-config`).

WARNING: Direct SSH access to machines is not recommended; instead,
make configuration changes via `machineconfig` objects:
  https://docs.openshift.com/container-platform/4.7/architecture/architecture-rhcos.html

---
[bound] -bash-4.4$ rpm-ostree status
State: idle
Deployments:
* ostree://d1d016103377968db034641fd7430ac23c56779c78448932bbddd2ce738f66a6
                   Version: 47.84.202206131038-0 (2022-06-13T10:41:41Z)

Comment 9 errata-xmlrpc 2022-07-14 04:47:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.54 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:5505