Bug 2082008

Summary: LiveMigration fails due to loss of connection to destination host
Product: Container Native Virtualization (CNV) Reporter: Antonio Cardace <acardace>
Component: VirtualizationAssignee: Antonio Cardace <acardace>
Status: CLOSED ERRATA QA Contact: vsibirsk
Severity: high Docs Contact:
Priority: high    
Version: 4.8.3CC: akrgupta, cnv-qe-bugs, kbidarka, ycui
Target Milestone: ---   
Target Release: 4.11.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: hco-bundle-registry-container-v4.11.0-491 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-09-14 19:31:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Comment 2 Antonio Cardace 2022-05-12 12:36:24 UTC
Posted https://github.com/kubevirt/kubevirt/pull/7732 that fixes this.

Comment 4 Akriti Gupta 2022-07-04 13:55:03 UTC
Verified with  v4.11.0-513

we tested it by creating a lot of load on cluster using migration storm testcase that created aroud 20 VMs and migrated them to and fro,
we migrated the vm miltiple times ,checked all the virt-hanlder logs didn't encoounter any issue.

[akrgupta@fedora auth]$ oc -n openshift-cnv logs -f virt-handler-27cbx | grep "server error. command Migrate failed"
^C
[akrgupta@fedora auth]$ oc -n openshift-cnv logs -f virt-handler-9nm9j | grep "server error. command Migrate failed"
^C
[akrgupta@fedora auth]$ oc -n openshift-cnv logs -f virt-handler-k8lqr | grep "server error. command Migrate failed"
^C
[akrgupta@fedora auth]$

As this could be hard to reproduce easily, feel free to re-open this bug , if needed

Comment 5 Kedar Bidarkar 2022-07-04 17:26:06 UTC
As per comment 4, moving this bug to VERIFIED state.

Comment 7 errata-xmlrpc 2022-09-14 19:31:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Important: OpenShift Virtualization 4.11.0 Images security and bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2022:6526