Bug 20839

Summary: Kernel version not consist with include file in /usr/include/linux
Product: [Retired] Red Hat Linux Reporter: rhcohen <rcohen>
Component: kernelAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: dr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-11-15 08:02:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description rhcohen 2000-11-14 17:40:47 UTC
RedHat 7.0 uses kernel version 2.2.16-22.  This is the response from a uname -r command.  However, the version.h file in /usr/include/linux has 
version 2.4.0-0.26.  The version.h file in /usr/src/linux-2.2.16/include/linux shows the 2.2.16-22 version.  Other include files in /usr/include/linux 
do not match the same include files in /usr/src/linux-2.2.16/include/linux.  The Linux kernel version should be 2.2.16-22 not 2.4.0-0.26.

Comment 1 Greg Kroah-Hartman 2000-11-15 00:06:07 UTC
crap, I should have searched the previous bug reports before submitting this
one, sorry.

But if 'make mrproper' is the "proper" way to build the kernel from the
kernel-source package, you might want to modify the kernel-2.2.spec spec file to
not include the include/modules directory.

Although in looking at that spec file, I really can't see how to do that, sorry.

Comment 2 Greg Kroah-Hartman 2000-11-15 00:07:43 UTC
forget that last comment, I added that to the wrong bug.  Sorry.

Comment 3 Arjan van de Ven 2000-11-15 08:02:29 UTC
The headers in /usr/include are glibc headers, not kernel headers.
The kernel headers are in /usr/src/linux/include. These happened to be the
same in the past but for compatibility reasons, are not now.
This bug is a dupe btw..