Bug 2084110

Summary: [OVN] EgressIP NATs are not being cleared correctly from the logical router
Product: OpenShift Container Platform Reporter: Andre Costa <andcosta>
Component: NetworkingAssignee: ffernand <ffernand>
Networking sub component: ovn-kubernetes QA Contact: huirwang
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: bpickard, cldavey, ffernand, mwasher, openshift-bugs-escalate, pdiak, rravaiol, surya, vlours
Version: 4.8Keywords: FastFix
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 2088626 (view as bug list) Environment:
Last Closed: 2022-06-16 18:23:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2088630    
Bug Blocks:    

Comment 14 ffernand 2022-05-25 20:46:12 UTC
Backporting changes to release 4.8z where logical_port is kept up to date with the node where egress ip is scheduled.

https://github.com/openshift/ovn-kubernetes/pull/1107

Comment 21 errata-xmlrpc 2022-06-16 18:23:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.43 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:4952