Bug 208489

Summary: virsh list fails with glibc detected invalid next size
Product: [Fedora] Fedora Reporter: Brian Brock <bbrock>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.1.7-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-11-06 06:31:50 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Brian Brock 2006-09-28 16:35:08 EDT
running `virsh list` causes glibc to generate an error message, and then the
command fails.

libvirt-0.1.6-1
xen-3.0.2-39
kernel-xen-2.6.18-1.2699.fc6
glibc-2.4.90-36
rawhide-20060928 tree

seems reliable reproducible.

virsh returns 134

backtrace and memory map:
*** glibc detected *** virsh: free(): invalid next size (normal): 0x08b36a68 ***
======= Backtrace: =========
/lib/i686/nosegneg/libc.so.6[0xc85c6d]
/lib/i686/nosegneg/libc.so.6(cfree+0x90)[0xc89320]
/usr/lib/libvirt.so.0[0x19d96f]
/usr/lib/libvirt.so.0(virConnectNumOfDomains+0x68)[0x19573f]
virsh[0x804be2a]
virsh[0x804d2ee]
virsh[0x804da7a]
/lib/i686/nosegneg/libc.so.6(__libc_start_main+0xdc)[0xc34f2c]
virsh[0x8049611]
======= Memory map: ========
00111000-00113000 r-xp 00000000 fd:00 24018975   /lib/libdl-2.4.90.so
00113000-00114000 r--p 00001000 fd:00 24018975   /lib/libdl-2.4.90.so
00114000-00115000 rw-p 00002000 fd:00 24018975   /lib/libdl-2.4.90.so
00115000-00120000 r-xp 00000000 fd:00 24018946   /lib/libgcc_s-4.1.1-20060926.so.1
00120000-00121000 rw-p 0000a000 fd:00 24018946   /lib/libgcc_s-4.1.1-20060926.so.1
00187000-0018b000 r-xp 00000000 fd:00 25862109   /usr/lib/libxenstore.so.3.0.0
0018b000-0018c000 rw-p 00003000 fd:00 25862109   /usr/lib/libxenstore.so.3.0.0
0018c000-0018f000 rw-p 0018c000 00:00 0 
00192000-001ab000 r-xp 00000000 fd:00 25862203   /usr/lib/libvirt.so.0.1.6
001ab000-001ac000 rw-p 00018000 fd:00 25862203   /usr/lib/libvirt.so.0.1.6
001e9000-00202000 r-xp 00000000 fd:00 24018962   /lib/ld-2.4.90.so
00202000-00203000 r--p 00018000 fd:00 24018962   /lib/ld-2.4.90.so
00203000-00204000 rw-p 00019000 fd:00 24018962   /lib/ld-2.4.90.so
00245000-00258000 r-xp 00000000 fd:00 24018956  
/lib/i686/nosegneg/libpthread-2.4.90.so
00258000-00259000 r--p 00012000 fd:00 24018956  
/lib/i686/nosegneg/libpthread-2.4.90.so
00259000-0025a000 rw-p 00013000 fd:00 24018956  
/lib/i686/nosegneg/libpthread-2.4.90.so
0025a000-0025c000 rw-p 0025a000 00:00 0 
0030e000-0033d000 r-xp 00000000 fd:00 25857514   /usr/lib/libreadline.so.5.1
0033d000-00341000 rw-p 0002f000 fd:00 25857514   /usr/lib/libreadline.so.5.1
00341000-00342000 rw-p 00341000 00:00 0 
0042d000-00452000 r-xp 00000000 fd:00 24018954   /lib/i686/nosegneg/libm-2.4.90.so
00452000-00453000 r--p 00024000 fd:00 24018954   /lib/i686/nosegneg/libm-2.4.90.so
00453000-00454000 rw-p 00025000 fd:00 24018954   /lib/i686/nosegneg/libm-2.4.90.so
00a79000-00ab9000 r-xp 00000000 fd:00 25857480   /usr/lib/libncurses.so.5.5
00ab9000-00ac1000 rw-p 00040000 fd:00 25857480   /usr/lib/libncurses.so.5.5
00ac1000-00ac2000 rw-p 00ac1000 00:00 0 
00c1f000-00d5a000 r-xp 00000000 fd:00 24018952   /lib/i686/nosegneg/libc-2.4.90.so
00d5a000-00d5c000 r--p 0013a000 fd:00 24018952   /lib/i686/nosegneg/libc-2.4.90.so
00d5c000-00d5d000 rw-p 0013c000 fd:00 24018952   /lib/i686/nosegneg/libc-2.4.90.so
00d5d000-00d60000 rw-p 00d5d000 00:00 0 
00e0d000-00e1f000 r-xp 00000000 fd:00 25857379   /usr/lib/libz.so.1.2.3
00e1f000-00e20000 rw-p 00011000 fd:00 25857379   /usr/lib/libz.so.1.2.3
00e4c000-00f78000 r-xp 00000000 fd:00 25857523   /usr/lib/libxml2.so.2.6.26
00f78000-00f7d000 rw-p 0012b000 fd:00 25857523   /usr/lib/libxml2.so.2.6.26
00f7d000-00f7e000 rw-p 00f7d000 00:00 0 
08048000-08050000 r-xp 00000000 fd:00 25862201   /usr/bin/virsh
08050000-08051000 rw-p 00008000 fd:00 25862201   /usr/bin/virsh
08b35000-08b56000 rw-p 08b35000 00:00 0 
b7c00000-b7c21000 rw-p b7c00000 00:00 0 
b7c21000-b7d00000 ---p b7c21000 00:00 0 
b7d13000-b7f13000 r--p 00000000 fd:00 25857373   /usr/lib/locale/locale-archive
b7f13000-b7f16000 rw-p b7f13000 00:00 0 
b7f1b000-b7f1c000 rw-p b7f1b000 00:00 0 
b7f1c000-b7f1d000 r-xp b7f1c000 00:00 0          [vdso]
bf7f4000-bf80a000 rw-p bf7f4000 00:00 0          [stack]
Aborted

Command was expected to complete without error message and print a list of domains
Comment 1 Daniel Veillard 2006-11-06 06:31:50 EST
I think this was a problem of change of size of the getdomaininfo struct between
xen-3.0.2 and 3.0.3, probably corrupting the malloc memory lists and raising that
error on the next block allocated. I guess this was fixed in libvirt-0.1.7 
If not can you reopen the bug, I didn't see this error since then,

Daniel