Bug 208809

Summary: No Support for Samsung ML-1740 Printer
Product: [Fedora] Fedora Reporter: Don Mies <don.mies>
Component: foomaticAssignee: Tim Waugh <twaugh>
Status: CLOSED INSUFFICIENT_DATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: dcantrell, deisenst
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 3.0.2-39.4.fc6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-31 12:57:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 219467, 207681    
Attachments:
Description Flags
/usr/share/foomatic/db/source/printer/Samsung-ML-1740.xml
none
/usr/share/foomatic/db/source/driver/gdi.xml none

Description Don Mies 2006-10-02 05:08:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.6) Gecko/20060808 Fedora/1.5.0.6-2.fc5 Firefox/1.5.0.6 pango-text

Description of problem:
When trying to configure my printer I get the following:

No match for USB device:
  mfr "Samsung"
  model "ML-1740"
  desc ""
  cmdset "GDI"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.


Version-Release number of selected component (if applicable):
kernel 2.6.17-1.2187_FC5

How reproducible:
Always


Steps to Reproduce:
1.Bring up the printer config GUI
2.Add a new printer (attached via USB) My printer is correctly detected.
3.Hit "apply" and the error occurs in the window that invoked the GUI.

Actual Results:
The above error message appears and the printer does not work.

Expected Results:
No error and a working printer.

Additional info:
I tried using a different driver such as the HP driver with the same result.

Comment 1 David Eisenstein 2006-10-28 06:21:12 UTC
I get the same message for my Samsung ML-1740 printer.  My hardware is
i386 (though the platform shouldn't matter).

Comment 2 David Eisenstein 2006-10-28 07:09:40 UTC
Hey Don --

I found that by:
  1) running 'printtool' as root, 
  2) selecting the Samsung print queue,
  3) pressing "Edit" button (opens "Edit a print queue" dialog box),
  4) selecting the tab "Printer Driver" in the "Edit a print queue" dialog box,
  5) then selecting Samsung ML-1710 as the printer driver,

I could get my Samsung ML-1740 printer to work okay.  I had had my ML-1740
working in Fedora Core 1, and I believe this was the solution I had adopted
there as well.

Don, why don't you give this a try, and let us know if it works for you too?
If so, then perhaps Tim Waugh could make Samsung-ML-1740.ppd file using the
contents of the ML-1710 one, and place it in fc5's foomatic to help others
with this problem.

Hope this helps.  -David

Comment 3 Tim Waugh 2006-11-13 10:18:44 UTC
This should be fixed now in Fedora Core 6 plus the updates from updates-testing.

Comment 5 Fedora Update System 2007-01-17 16:27:15 UTC
Fixed in update: foomatic-3.0.2-39.4.fc6

Comment 6 David Eisenstein 2007-01-21 05:20:55 UTC
This bug was submitted for Fedora Core 5, not Fedora Core 6.  As such, the
solution proposed is not solving the problem originally submitted (before
FC6 even came out), though it's nice to have it solved for FC6 users.

Could this fix be easily be backported to FC5?  If so, there is no reason it 
cannot also be fixed for FC5.  Or have FC5's foomatic updated in a similar way
without issues?

Since community members are now supposed to start being able to contribute to
Core, would an offer be accepted from a community member to help get this 
backported or updated in FC5?  Like a submission of a .src.rpm or something?

Comment 7 Tim Waugh 2007-01-22 12:18:26 UTC
Created attachment 146164 [details]
/usr/share/foomatic/db/source/printer/Samsung-ML-1740.xml

Comment 8 Tim Waugh 2007-01-22 12:19:25 UTC
Created attachment 146165 [details]
/usr/share/foomatic/db/source/driver/gdi.xml

Please try installing these files in the indicated directories.  There will be
an existing gdi.xml that you need to overwrite.

Does this allow you to print?

Comment 9 David Eisenstein 2007-01-23 09:51:52 UTC
I cannot access attachment 146164 [details] ...  "Access Denied" error page comes up.

Comment 10 Tim Waugh 2007-01-23 10:01:27 UTC
Oops.. try now.

Comment 11 David Eisenstein 2007-01-28 14:03:54 UTC
Okay, I imported the files you specified in comment #7 and comment #8 to the
locations you specified and then tried running printtool:

-----------------------------------------------
# printtool
No match for USB device:
  mfr "Samsung"
  model "ML-1740"
  desc ""
  cmdset "GDI"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
-----------------------------------------------

Also, Samsung ML-1740 does not appear among the printers listed in the
printer driver tab of "Edit a print queue" dialog box.


Comment 12 Tim Waugh 2007-02-09 11:36:05 UTC
Please run 'rm -f /var/cache/foomatic/*' and try again.