Bug 2089399

Summary: Deprecation of SQLite database backend in Bacula
Product: Red Hat Enterprise Linux 8 Reporter: Pavel Cahyna <pcahyna>
Component: baculaAssignee: Pavel Cahyna <pcahyna>
Status: CLOSED MIGRATED QA Contact: CS System Management SST QE <rhel-cs-system-management-subsystem-qe>
Severity: unspecified Docs Contact: Šárka Jana <sjanderk>
Priority: unspecified    
Version: ---CC: rhel-cs-system-management-subsystem-qe
Target Milestone: rcKeywords: MigratedToJIRA, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Deprecated Functionality
Doc Text:
.The SQLite database backend in Bacula has been deprecated The Bacula backup system supported multiple database backends: PostgreSQL, MySQL, and SQLite. The SQLite backend has been deprecated and will become unsupported in a later release of RHEL. As a replacement, migrate to one of the other backends (PostgreSQL or MySQL) and do not use the SQLite backend in new deployments.
Story Points: ---
Clone Of: 2089395 Environment:
Last Closed: 2023-09-21 22:08:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2089395    
Bug Blocks:    

Description Pavel Cahyna 2022-05-23 15:00:41 UTC
+++ This bug was initially created as a clone of Bug #2089395 +++

The Bacula backup system has support for multiple database backends: PostgreSQL, MySQL, and SQLite. The SQLite backend is deprecated and will become unsupported in a later release of RHEL. Users are advised to migrate to one of the other backends and to not use the SQLite backend in new deployments.

( upstream documentation for version 11 - included in RHEL 9 - is here: https://www.bacula.org/11.0.x-manuals/en/main/Current_State_Bacula.html )

Comment 2 RHEL Program Management 2023-09-21 21:32:08 UTC
Issue migration from Bugzilla to Jira is in process at this time. This will be the last message in Jira copied from the Bugzilla bug.

Comment 3 RHEL Program Management 2023-09-21 22:08:04 UTC
This BZ has been automatically migrated to the issues.redhat.com Red Hat Issue Tracker. All future work related to this report will be managed there.

Due to differences in account names between systems, some fields were not replicated.  Be sure to add yourself to Jira issue's "Watchers" field to continue receiving updates and add others to the "Need Info From" field to continue requesting information.

To find the migrated issue, look in the "Links" section for a direct link to the new issue location. The issue key will have an icon of 2 footprints next to it, and begin with "RHEL-" followed by an integer.  You can also find this issue by visiting https://issues.redhat.com/issues/?jql= and searching the "Bugzilla Bug" field for this BZ's number, e.g. a search like:

"Bugzilla Bug" = 1234567

In the event you have trouble locating or viewing this issue, you can file an issue by sending mail to rh-issues. You can also visit https://access.redhat.com/articles/7032570 for general account information.