Bug 209252

Summary: vm-applet tooltip always displays: "Failed to load information about virtual domains"
Product: [Fedora] Fedora Reporter: Dave Malcolm <dmalcolm>
Component: gnome-applet-vmAssignee: Karel Zak <kzak>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-03 09:40:20 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dave Malcolm 2006-10-03 22:29:32 EDT
Description of problem:
I'm running vm-applet on Linux brick 2.6.18-1.2726.fc6xen #1 SMP Mon Oct 2
20:02:58 EDT 2006 i686 i686 i386 GNU/Linux

I have no guest domains.

Mouseover on the vm-applet always displays this tooltip:
"Failed to load information about virtual domains"

Version-Release number of selected component (if applicable):
gnome-applet-vm-0.1.0-1
kernel-xen-2.6.18-1.2726.fc6
xen-3.0.2-42
libvirt-0.1.7-1


How reproducible:
100%

Expected results:
Should either display info on the dom0 and the empty list of guests, or say
something like "you have no guests".  Or is it an error grabbing the data?  I
don't know how to debug further (suggestions welcome!)
Comment 1 Dave Malcolm 2006-10-03 23:15:13 EDT
Doh!  I'm not running as root; works fine as root

Should the applet detect if you're not root and have a different error message
for this case?
Comment 2 Karel Zak 2008-03-03 09:40:20 EST
The applet has been completely rewritten, please check the latest version from
Fedora 9. Thanks.