Bug 2092732 (CVE-2022-26700, WSA-2022-0005)

Summary: CVE-2022-26700 webkitgtk: Processing maliciously crafted web content may lead to code execution
Product: [Other] Security Response Reporter: TEJ RATHI <trathi>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: NEW --- QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: erack, gnome-sig, mcatanza, tpopela
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: webkitgtk 2.36.3 Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in webkitgtk. The vulnerability occurs due to improper input validation, leading to memory corruption. This flaw allows an attacker with network access to pass specially crafted web content files, causing an application to halt, crash, or arbitrary code execution.
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2092748, 2092749, 2092741    
Bug Blocks: 2092738    

Description TEJ RATHI 2022-06-02 07:15:49 UTC
Processing maliciously crafted web content may lead to code execution. Description: A memory corruption issue was addressed with improved state management.

Versions affected: WebKitGTK and WPE WebKit before 2.36.3.

Comment 1 Sandipan Roy 2022-06-02 07:33:00 UTC
Created webkit2gtk3 tracking bugs for this issue:

Affects: fedora-all [bug 2092741]