Bug 2093333 (CVE-2022-30787)

Summary: CVE-2022-30787 ntfs-3g: integer underflow in fuse_lib_readdir enables arbitrary memory read operations
Product: [Other] Security Response Reporter: Guilherme de Almeida Suckevicz <gsuckevi>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: NEW --- QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: ddepaula, epel-packagers-sig, jferlan, kparal, ngompa13, rjones, spotrh, virt-maint
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: ntfs-3g 2022.5.17 Doc Type: If docs needed, set a value
Doc Text:
A vulnerability was found in NTFS-3G. An integer underflow in fuse_lib_readdir allows out-of-bounds read operations.
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2093336, 2093337, 2093334, 2093335, 2093338    
Bug Blocks: 2093356    

Description Guilherme de Almeida Suckevicz 2022-06-03 14:01:24 UTC
An integer underflow in fuse_lib_readdir enables arbitrary memory read operations in NTFS-3G through 2021.8.22 when using libfuse-lite.

References:
https://github.com/tuxera/ntfs-3g/security/advisories/GHSA-6mv4-4v73-xw58
https://github.com/tuxera/ntfs-3g/releases

Comment 1 Guilherme de Almeida Suckevicz 2022-06-03 14:01:50 UTC
Created ntfs-3g tracking bugs for this issue:

Affects: epel-all [bug 2093335]
Affects: fedora-all [bug 2093334]


Created ntfs-3g-system-compression tracking bugs for this issue:

Affects: epel-all [bug 2093336]
Affects: fedora-all [bug 2093338]


Created ntfs2btrfs tracking bugs for this issue:

Affects: fedora-all [bug 2093337]