Bug 2094581

Summary: Kernel 5.18 test week: performance regression (kaby lake)
Product: [Fedora] Fedora Reporter: itrymybest80
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 36CC: acaringi, adscvr, airlied, alciregi, bskeggs, hdegoede, hpa, jarodwilson, jforbes, jglisse, jonathan, josef, kernel-maint, lgoncalv, linville, masami256, mchehab, ptalbert, steved
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-06-08 15:15:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description itrymybest80 2022-06-07 23:19:11 UTC
My system performance has tanked following the 5.18 kernel upgrade with slower boot, file browsing, gaming performance and audio stutter.

Enabling "performance mode" doesn't help, but rebooting into 5.17.12 makes all tasks run like prior to the kernel upgrade.

The same game that would run at 57fps (over multiple runs) will drop to 45fps at the same scene and video playback on the web now has intermittent stutter.

I'm not running any modules that didn't ship directly with your kernel and it's reproducible on my end.

kernel-5.17.12-300.fc36.x86_64
kernel-5.17.13-300.fc36.x86_64
kernel-5.18.1-200.fc36.x86_64 (regression)
kernel-5.18.2-200.fc36.x86_64 (regression)
kernel-5.19.0-0.rc0.20220531git8ab2afa23bd1.8.fc37.x86_64 (regression)
kernel-5.19.0-0.rc1.20220607gite71e60cd74df.15.fc37.x86_64 (regression)

Fedora Linux 36 (Workstation Edition) x86_64 sv_SE.UTF-8
GNOME 42.2 / Mutter
Intel 200 Series / Z370 Chipset Family
Intel i5-7600K (4) @ 4.200GHz
2211MiB / 15935MiB (16GB)
Realtek ALC1220 / PipeWire 0.3.51 (i686, x86_64) WirePlumber 0.4.10
AMD Radeon RX 580 (LLVM 14.0.0, DRM 3.46) MESA 22.1.1

Comment 1 Justin M. Forbes 2022-06-08 15:15:41 UTC
Test again with 5.18.2-201 that should fix it.

Comment 2 itrymybest80 2022-06-08 15:54:49 UTC
Thank you so much! My apologies for overlooking your 201 build. My system performance is back to "normal" again.