Bug 2094695 (CVE-2022-1968)

Summary: CVE-2022-1968 vim: use-after-free in function utf_ptr2char at mbyte.c:1794
Product: [Other] Security Response Reporter: Marian Rehak <mrehak>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: gchamoul, karsten, michal.skrivanek, mperina, sbonazzo, zdohnal
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: vim 8.2.5050 Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in vim. The vulnerability occurs due to Illegal memory access and leads to a use-after-free vulnerability in the utf_ptr2char function. This flaw allows an attacker to input a specially crafted file, leading to a crash or code execution.
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-06-08 13:49:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 2094696    
Bug Blocks: 2094697    

Description Marian Rehak 2022-06-08 08:19:25 UTC
Use After Free in function utf_ptr2char at mbyte.c:1794.

Reference:

https://huntr.dev/bounties/949090e5-f4ea-4edf-bd79-cd98f0498a5b/

Comment 1 Marian Rehak 2022-06-08 08:19:40 UTC
Created vim tracking bugs for this issue:

Affects: fedora-all [bug 2094696]

Comment 2 Product Security DevOps Team 2022-06-08 13:49:42 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-1968