Bug 210046

Summary: xeninstall-guest.py is broken
Product: [Fedora] Fedora Reporter: Thorsten Scherf <tscherf>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: bstein, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-09 14:45:38 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
xend.log none

Description Thorsten Scherf 2006-10-09 14:31:29 EDT
Description of problem:
the install script is broken. it breaks after answering all questions...


Version-Release number of selected component (if applicable):
xen-3.0.2-44

How reproducible:
xen-guestinstall.py

Steps to Reproduce:
1.call the script
2.
3.
  
Actual results:
log message is:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 195,
in create
    vm.initDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 1363,
in initDomai
n
    raise VmError(str(exn))
VmError: (22, 'Invalid argument')
[2006-10-09 19:59:29 xend.XendDomainInfo 4103] DEBUG (XendDomainInfo:1449)
XendDomainInfo.des
troy: domid=4
[2006-10-09 19:59:29 xend.XendDomainInfo 4103] DEBUG (XendDomainInfo:1457)
XendDomainInfo.des
troyDomain(4)
[2006-10-09 19:59:29 xend 4103] ERROR (SrvBase:88) Request create failed.
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/web/SrvBase.py", line 85, in perform
    return op_method(op, req)
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
82, in op_cre
ate
    raise XendError("Error creating domain: " + str(ex))
XendError: Error creating domain: (22, 'Invalid argument')
(END) 

full log is attached


Expected results:
building up the guest image 

Additional info:
Comment 1 Thorsten Scherf 2006-10-09 14:31:29 EDT
Created attachment 138061 [details]
xend.log
Comment 2 Thorsten Scherf 2006-10-09 14:42:10 EDT
name: webserver
ram: 256
disk image size: 3
location: /mnt/vmware/websever.img
install location: http://localhost/pub/fedora/fc5
or nfs:192.168.0.99:/var/ftp/pub/fedora/fc5

then it breaks.
Comment 3 Jeremy Katz 2006-10-09 14:45:38 EDT
FC5 guest on FC6 host cannot work for x86 due to the PAE switch
Comment 4 Stephen Tweedie 2006-10-09 15:30:09 EDT
Note that if you install an FC5 guest (eg. using an FC5 dom0) and then manually
add the FC5 "kernel-xen" RPM in the guest, you can then boot that kernel from an
FC6 dom0.  But there is no PAE-compatible kernel on the FC5 install media, so a
paravirt fresh install of FC5 on an FC6 host is not possible.