Bug 2102862

Summary: Build with the i915g driver enabled?
Product: [Fedora] Fedora Reporter: Jean-Fran├žois Fortin Tam <nekohayo>
Component: mesaAssignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 36CC: ajax, bskeggs, caillon+fedoraproject, igor.raits, jglisse, j, lyude, mail, rclark, rhughes, rstrode, tstellar, walter.pete
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-07-14 02:43:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Jean-Fran├žois Fortin Tam 2022-06-30 20:47:52 UTC
Users of some Intel Core2 systems (like the Dell Inspiron 530n that I have, which Dell officially shipped with Linux available preinstalled) would benefit from being able to run the latest GTK4 apps and GNOME Shell / Mutter / etc. on the GPU, if at all possible.

Mesa recently deprecated the i915 driver, favoring the i915g driver as its replacement, as far as I understand.

However, from https://ask.fedoraproject.org/t/how-do-i-tell-fedora-to-use-the-i915g-driver-instead-of-i915/20618/ it seems the i915g driver is not built by default in the mesa packages provided by Fedora.

Building packages myself is way beyond my skillset, and I would appreciate my OS providing those drivers for me out of the box.

Comment 1 Pete Walter 2022-07-14 02:43:41 UTC

*** This bug has been marked as a duplicate of bug 2100212 ***