Bug 2105664

Summary: 8APIRequestCount does not identify some APIs removed in 4.8
Product: OpenShift Container Platform Reporter: Luis Sanchez <sanchezl>
Component: kube-apiserverAssignee: Luis Sanchez <sanchezl>
Status: CLOSED ERRATA QA Contact: Zimo Xiao <zxiao>
Severity: high Docs Contact:
Priority: high    
Version: 4.7CC: kewang, mfojtik, openshift-bugzilla-robot, sdodson, wking, wlewis, xxia
Target Milestone: ---   
Target Release: 4.8.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 2105663 Environment:
Last Closed: 2022-08-09 12:52:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2105663    
Bug Blocks:    

Comment 2 Zimo Xiao 2022-07-22 05:47:24 UTC
Base on PR changes, I created a 4.8 nightly cluster with version 4.8.0-0.nightly-2022-07-21-200907 and k8s version 1.22 which includes this PR merge. 

Then I run:
$ oc get apirequestcounts xxx

on the following APIs:
> apiservices.v1beta1.apiregistration.k8s.io
> tokenreviews.v1beta1.authentication.k8s.io
> localsubjectaccessreviews.v1beta1.authorization.k8s.io
> selfsubjectaccessreviews.v1beta1.authorization.k8s.io
> subjectaccessreviews.v1beta1.authorization.k8s.io
> leases.v1beta1.coordination.k8s.io
> ingressclasses.v1beta1.networking.k8s.io
> csidrivers.v1beta1.storage.k8s.io
> storageclasses.v1beta1.storage.k8s.io
> volumeattachments.v1beta1.storage.k8s.io

all APIs returned:
> NAME  REMOVEDINRELEASE   REQUESTSINCURRENTHOUR   REQUESTSINLAST24H
> xxx       1.22               1                       1

which shows that the APIs are removed in k8s version 1.22, which is expected by this merge. The test passed, so move the bug VERIFIED.

Comment 5 errata-xmlrpc 2022-08-09 12:52:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.47 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:5889