Bug 2105915

Summary: Allow specific permissions to be excluded from being added to default roles
Product: Red Hat Satellite Reporter: Leos Stejskal <lstejska>
Component: ProvisioningAssignee: Adam Ruzicka <aruzicka>
Status: CLOSED NOTABUG QA Contact: sganar
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.8.0CC: inecas, sshtein
Target Milestone: 6.12.0Keywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-07-11 13:14:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Leos Stejskal 2022-07-11 07:41:09 UTC
If I understood the permission related helpers in app/registries/plugin.rb we have a couple options:

1) add_permissions_to_default_roles - Here I'd need to list ALL the permissions except the one I don't want included. Also one needs to separate the different permissions for viewer/manager by hand. Apart from it being ugly, I couldn't manage to get it working at all. All attempts failed with
<pre>
foreman/app/models/role.rb:336:in `permission_records': ERF73-0602 [Foreman::PermissionMissingException]: »some permissions were not found: []« (Foreman::PermissionMissingException)
</code></pre>

2) add_resource_permissions_to_default_roles - Here I'd need to list all the resources and according to the comment above the method I should be able to pass an array of permissions to be excluded. Sounds good, doesn't work. Interestingly enough, all attempts failed with the same error as option 1.

Here I propose to add a keyword argument "except" to add_all_permissions_to_default_roles, which would prevent listed permissions from being added to the default roles. It is more inline with the idea of "add all permissions except for the selected few" rather than "to exclude this permission, I need to explicitly state all that should be included"

Comment 1 Leos Stejskal 2022-07-11 07:41:14 UTC
Created from redmine issue https://projects.theforeman.org/issues/34329

Comment 2 Leos Stejskal 2022-07-11 07:41:15 UTC
Upstream bug assigned to aruzicka

Comment 3 Bryan Kearney 2022-07-11 08:04:53 UTC
Upstream bug assigned to aruzicka

Comment 4 Bryan Kearney 2022-07-11 08:04:54 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/34329 has been resolved.

Comment 5 Leos Stejskal 2022-07-11 13:14:31 UTC
Closing the BZ,
we decided to not cherry-pick it to 6.11