Bug 2108328

Summary: Wine recommends isdn4k-utils, but nothing provides it
Product: [Fedora] Fedora Reporter: Göran Uddeborg <goeran>
Component: wineAssignee: Michael Cronenworth <mike>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 36CC: andreas.bierfert, besser82, mike
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: wine-7.18-2.fc36 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-10-22 13:50:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Göran Uddeborg 2022-07-18 21:06:10 UTC
Description of problem:
The package "wine" recommends isdn4k-utils(x86-64) and isdn4k-utils(x86-32), but nothing in the distribution provides it as far as I can tell.


Version-Release number of selected component (if applicable):
wine-7.2-1.fc36


Steps to Reproduce:
1. dnf repoquery --recommends wine.x86_64
2. dnf repoquery --whatprovides 'isdn4k-utils(x86-64)'


Actual results:
The first command returns (among a few other things) isdn4k-utils(x86-64) and isdn4k-utils(x86-32). The second returns nothing.


Expected results:
I would have expected anything recommended by a package in the repo to also be provided by some package in the repo.


Additional info:
Since this is about the weak requirement "recommends", it doesn't really break anything. But I assume it still is wrong.

Comment 1 Michael Cronenworth 2022-07-18 21:34:11 UTC
It looks like over time the recommends was improperly exposed. It was hidden at one point to Fedora versions less than 31. It just needs to go away at this point. I'll remove it in the next update. Thanks.

Comment 2 Fedora Update System 2022-10-12 00:45:26 UTC
FEDORA-2022-e3517556b0 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-e3517556b0

Comment 3 Fedora Update System 2022-10-12 00:45:53 UTC
FEDORA-2022-da3e41e946 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-da3e41e946

Comment 4 Fedora Update System 2022-10-12 09:39:01 UTC
FEDORA-2022-e3517556b0 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-e3517556b0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-e3517556b0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-10-12 13:02:39 UTC
FEDORA-2022-da3e41e946 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-da3e41e946`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-da3e41e946

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-10-14 10:30:36 UTC
FEDORA-2022-e3517556b0 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-e3517556b0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-e3517556b0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2022-10-14 14:37:41 UTC
FEDORA-2022-da3e41e946 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-da3e41e946`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-da3e41e946

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-10-22 13:50:58 UTC
FEDORA-2022-da3e41e946 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-11-15 01:14:57 UTC
FEDORA-2022-e3517556b0 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.