Bug 211118

Summary: Unable to connect to xend with xen Dom0 kernel and xend running
Product: [Fedora] Fedora Reporter: das_deniz
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: bstein, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-17 12:25:02 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description das_deniz 2006-10-17 10:41:03 EDT
Description of problem:

after yum kernel update and reboot 'xm list' reports

Error: Unable to connect to xend: No such file or directory. Is xend running?


Version-Release number of selected component (if applicable):

kernel-2.6.18-1.2784.fc6

How reproducible:

always.

Steps to Reproduce:
1. yum update
2. /etc/sysconfig/kernel has kernel-xen
3. boot/grub/grub.conf defaults to fc6xen
4. boot
5. xm list
  
Actual results:

uname -r
2.6.18-1.2798.fc6xen

/etc/init.d/xend status
xend is running

xm list
Error: Unable to connect to xend: No such file or directory. Is xend running?

Expected results:

xen should be happy !

Additional info:
Comment 1 Daniel Veillard 2006-10-17 11:03:52 EDT
so it's not kernel-2.6.18-1.2784.fc6 but
kernel-xen-2.6.18-1.2798.fc6 which is at fault
In this case this looks like a duplicate of 211097

Can you check you don't get the problem with kernel-xen-2.6.18-1.2784.fc6
Can you confirm it's x86_64 and not i686 ?

thanks

Daniel
Comment 2 das_deniz 2006-10-17 11:26:21 EDT
problem is with 2798.fc6xen
after rebooting into 2784.fc6xen 
xm list is fine

Name        ID Mem(MiB) VCPUs State   Time(s)
Domain-0     0     2904     1 r-----     26.6

platform is i686
model name: Intel(R) Pentium(R) 4 CPU 2.80GHz
Comment 3 das_deniz 2006-10-17 12:06:09 EDT
my related versions...

kernel-xen-2.6.18-1.2784.fc6
kernel-xen-2.6.18-1.2798.fc6
libvirt-0.1.7-2
libvirt-python-0.1.7-2
python-xeninst-0.94.0-1
virt-manager-0.2.3-2.fc6
virt-manager-debuginfo-0.2.3-2.fc6
xen-3.0.2-44
xen-libs-3.0.2-44

and, if as suggested in bug 211097, it is related to the fri 13th checkin
  rpm -q kernel-xen-2.6.18-1.2798.fc6 --changelog
...
* Fri Oct 13 2006 Juan Quintela <quintela@redhat.com> 
- update xen HV cset 11740.
- xen kernel update:
  * linux-2.6-xen-fedora changeset:   36227:84594d199837
  * xen-3.0.3-testing changeset:   11740:64b3e8596dc9
  * linux-2.6-xen-3.0.3 changeset:   22940:410c17270c74
  * remove all the blktap patches already included upstream.
...

maybe we're missing a paired update to xen-3.0.3 ???
Comment 4 Daniel Veillard 2006-10-17 12:25:02 EDT
Okay this really seems to be a dup of bug 211097, this is being worked on ...

Daniel

*** This bug has been marked as a duplicate of 211097 ***